1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10
​5
​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10
​100
​​ , and that its total digit number is less than 100.

Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
/*
    题意:比较两个浮点数,看保留到机器上的 n 位是否相同 n<100
            因为输入的数小等于10^100 即便是long long类型 输入的数 也远远超过2^63 - 1
            因此要用字符串来 代替数字
            这道题很坑,一定要注意输出要求的标准形式 全部都必须是0.s[0]s[1].... * 10^e
            千万要跳出这个坑
*/
#include <iostream>
using namespace std;
#include <string>
#include <algorithm>
int n;

string deal(string s, int &e){
    //先去除前导零
    int k = 0; //s的下标
    while(s.length() > 0 && s[0] == '0'){
        s.erase(s.begin());
    }
    //若去除前导零后,是小于1的数
    if(s[0] == '.'){
        s.erase(s.begin());
        while(s.length() > 0 && s[0] == '0'){ //找到第一个非零位的数 同时删掉其前导零
            s.erase(s.begin());
            e--; //小数点后 每次去掉一个前导0 指数e减一
        }
    }else{ //否则说明是大等于1的数 若后面有小数 找到小数点并删去小数点
        while(s.length() > k && s[k] != '.'){
            k++;
            e++;
        }
        if(k < s.length()) s.erase(s.begin() + k); //如果中途碰到了小数点 就删掉
    }
    
    if(s.length() == 0) e = 0; //若去除前导零后s的长度变为0,说明这个数是0
    
    /*
        上面的步骤 已经将 字符串变为 一串无前导零且无小数点的 数
        此时只需要用一个新的string来 存储n位数字即可
    */
    int num = 0;
    k = 0;
    string res;
    while(num < n){ //只要精度还没有到n
        if(k < s.length()) res += s[k++]; //只要还有数字 就加到res末尾
        else res += '0'; //否则res末尾添加0
        num++; //精度加1
    }
    return res;
}
int main(){
    cin >> n;
    string s1, s2, s3, s4;
    cin >> s1 >> s2;
    
    int e1 = 0, e2 = 0;
    s3 = deal(s1, e1);
    s4 = deal(s2, e2);
    
    if(s3 == s4 && e1 == e2){ //数相同,指数也得相同
        cout << "YES 0." << s3 << "*10^" << e1 << endl;
    }else{
        cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Here is the function template for isEqualTo: ``` template<typename T> bool isEqualTo(const T& a, const T& b) { return a == b; } ``` Here is an example program that uses isEqualTo with built-in types: ``` #include <iostream> int main() { std::cout << std::boolalpha; std::cout << isEqualTo(5, 5) << std::endl; std::cout << isEqualTo(5, 7) << std::endl; std::cout << isEqualTo('a', 'a') << std::endl; std::cout << isEqualTo('a', 'b') << std::endl; std::cout << isEqualTo(true, true) << std::endl; std::cout << isEqualTo(true, false) << std::endl; std::cout << isEqualTo(3.14, 3.14) << std::endl; std::cout << isEqualTo(3.14, 2.71) << std::endl; return 0; } ``` When we attempt to run this program with the user-defined class type Complex, we get a compilation error because the compiler doesn't know how to compare two Complex objects. To fix this, we can overload the equality operator in the Complex class: ``` class Complex { public: Complex(double real, double imag) : m_real(real), m_imag(imag) {} double real() const { return m_real; } double imag() const { return m_imag; } private: double m_real; double m_imag; }; bool operator==(const Complex& lhs, const Complex& rhs) { return lhs.real() == rhs.real() && lhs.imag() == rhs.imag(); } ``` Now when we attempt to run the program with Complex objects, it works as expected: ``` #include <iostream> class Complex { public: Complex(double real, double imag) : m_real(real), m_imag(imag) {} double real() const { return m_real; } double imag() const { return m_imag; } private: double m_real; double m_imag; }; bool operator==(const Complex& lhs, const Complex& rhs) { return lhs.real() == rhs.real() && lhs.imag() == rhs.imag(); } template<typename T> bool isEqualTo(const T& a, const T& b) { return a == b; } int main() { std::cout << std::boolalpha; std::cout << isEqualTo(Complex(1.0, 2.0), Complex(1.0, 2.0)) << std::endl; std::cout << isEqualTo(Complex(1.0, 2.0), Complex(3.0, 4.0)) << std::endl; return 0; } ``` Output: ``` true false ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值