1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目大意:给一个有向图,判断给定序列是否是拓扑序列~

#include <iostream>
#include <vector>
#include <cstring>
using namespace std;
/*
    首先肯定得建立 拓扑图
    用vector来建立 邻接表
    
*/  
int n, m; //顶点数 和 边数
vector<int> v[1010]; //保存每个顶点的出度
int in[1010]; //保存 每个顶点的 入度

bool istopo(vector<int> &ans){
	int in_c[1010];
	memcpy(in_c, in, sizeof(in_c)); //数组拷贝
   /* for(int i=0; i<n; i++){
        if(in_c[ans[i]] == 0){ //若当前顶点入度为零,那么需要将其指向的所有节点入度减一
            for(int j=0; j<v[ans[i]].size(); j++){
                in_c[v[ans[i]][j]]--;
            }
        }else{
            return false;
        }
    } */
    for(int i:ans){ //以后多多使用范围for 比较简洁
        if(in_c[i] == 0){
            for(int j:v[i]){
                in_c[j]--;
            }
        }else{
            return false;
        }
    }
    return true;
}
int main(){
    cin >> n >> m;
    
    int start, end;
    for(int i=0; i<m; i++){ //建立邻接表
        cin >> start >> end;
        v[start].push_back(end);
        in[end]++;
    }
    
    int k; //输入的序列数
    cin >> k;
    vector<int> ans(n), pos;
    for(int i=0; i<k; i++){ //对每个序列 进行验证是否为 拓扑序列
        for(int j=0; j<n; j++){
            cin >> ans[j];
        }
        if(istopo(ans)) continue;
        else pos.push_back(i);
    }
    
    for(int i=0; i<pos.size(); i++){
        if(i != pos.size() - 1){
            cout << pos[i] << " ";
        }else{
            cout << pos[i] << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值