springboot启动报错:o.a.catalina.core.AprLifecycleListener : An incompatible

springboot项目启动如下错误:

2019-08-14 09:46:11.804 ERROR 9556 --- [           main] o.a.catalina.core.AprLifecycleListener   : An incompatible version [1.1.29] of the APR based Apache Tomcat Native library is installed, while Tomcat requires version [1.2.14]
2019-08-14 09:46:11.975 ERROR 9556 --- [           main] o.a.catalina.core.AprLifecycleListener   : An incompatible version [1.1.29] of the APR based Apache Tomcat Native library is installed, while Tomcat requires version [1.2.14]
2019-08-14 09:46:12.086 ERROR 9556 --- [           main] o.a.catalina.core.AprLifecycleListener   : An incompatible version [1.1.29] of the APR based Apache Tomcat Native library is installed, while Tomcat requires version [1.2.14]

解决方案:
下载tcnative-1.ddl文件替换C:\Windows\System32下的 tcnative-1.ddl文件。
下载地址:http://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.14/binaries/

©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页