The Preliminary Contest for ICPC Asia Nanjing 2019 H Holy Grail

Holy Grail

Description

As the current heir of a wizarding family with a long history,unfortunately, you find yourself forced to participate in the cruel Holy Grail War which has a reincarnation of sixty years.However,fortunately,you summoned a Caster Servant with a powerful Noble Phantasm.When your servant launch her Noble Phantasm,it will construct a magic field,which is actually a directed graph consisting of n vertices and m edges.More specifically,the graph satisfies the following restrictions :

Does not have multiple edges(for each pair of vertices x and y, there is at most one edge between this pair of vertices in the graph) and does not have self-loops(edges connecting the vertex with itself).
May have negative-weighted edges.
Does not have a negative-weighted loop.
n<=300 , m<=500.
Currently,as your servant’s Master,as long as you add extra 6 edges to the graph,you will beat the other 6 masters to win the Holy Grail.

However,you are subject to the following restrictions when you add the edges to the graph:

Each time you add an edge whose cost is c,it will cost you c units of Magic Value.Therefore,you need to add an edge which has the lowest weight(it’s probably that you need to add an edge which has a negative weight).
Each time you add an edge to the graph,the graph must not have negative loops,otherwise you will be engulfed by the Holy Grail you summon.

Input
Input data contains multiple test cases. The first line of input contains integer t — the number of testcases (1 \le t \le 51≤t≤5).

For each test case,the first line contains two integers n,m,the number of vertices in the graph, the initial number of edges in the graph.

Then m lines follow, each line contains three integers x, y and w (0 \le x,y<n0≤x,y<n,-10^9−10 9 ≤w≤10^910 9 , x \not = yx =y) denoting an edge from vertices x to y (0-indexed) of weight w.

Then 6 lines follow, each line contains two integers s,t denoting the starting vertex and the ending vertex of the edge you need to add to the graph.

It is guaranteed that there is not an edge starting from s to t before you add any edges and there must exists such an edge which has the lowest weight and satisfies the above restrictions, meaning the solution absolutely exists for each query.

Output
For each test case,output 66 lines.

Each line contains the weight of the edge you add to the graph.

Examples
样例输入
1
10 15
4 7 10
7 6 3
5 3 3
1 4 11
0 6 20
9 8 25
3 0 9
1 2 15
9 0 27
5 2 0
7 3 -5
1 7 21
5 0 1
9 3 16
1 8 4
4 1
0 3
6 9
2 1
8 7
0 4
样例输出
-11
-9
-45
-15
17
7

题意

给你一个有向赋权图,可能有负边,但没有负环。给你6对点,让你添加6条边,添加的每一边都要做到权值最小,并且不能出现负环。问你这6条边的权值各是多少。

思路

因为不能出现负环,所以每次都反向找这两对点间的最短路即可。找到后,答案就是这条最短路的负数

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define ll long long
using namespace std;
#define maxn 305
#define inf 0x3f3f3f3f3f3f3f3f
struct Edge{
    int v, next;
    ll w;
}edge[maxn*2];
int head[maxn], cnt, n, m;
ll dis[maxn];
int vis[maxn];
void add_edge(int u, int v, ll w){
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

void spfa(int now){
    int i, j;
    queue<int> q;
    for(i = 0; i < n; i++){
    	dis[i] = inf;
    	vis[i] = 0;
    }
    dis[now] = 0;
    q.push(now);
    while(!q.empty()){
        int u = q.front();q.pop();
        vis[u] = 0;
        for(i = head[u]; i!=-1; i = edge[i].next){
            int v = edge[i].v;
            if(dis[v]>dis[u]+edge[i].w){
                dis[v] = dis[u] + edge[i].w;
                if(!vis[v]){
                    q.push(v);
                    vis[v] = 1;
                }
            }
        }
    }
}

int main(){
    int i, j, k, t, a, b;
    ll c;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(head, -1, sizeof(head));
        cnt = 0;
        for(i = 1; i <= m; i++){
            scanf("%d%d%lld",&a,&b,&c);
            add_edge(a,b,c);
        }
        for(i = 1; i <= 6; i++){
            scanf("%d%d",&a,&b);
            spfa(b);
            ll res = dis[a];
            add_edge(a,b,-res);
            printf("%lld\n",-res);
        }
    }
    
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值