The Preliminary Contest for ICPC Asia Nanjing 2019 D Robots

Robots

Given a directed graph with no loops which starts at node 11 and ends at node nn.
There is a robot who starts at 11, and will go to one of adjacent nodes or stand still with equal probability every day.
Every day the robot will have durability consumption which equals to the number of passed days.
Please calculate the expected durability consumption when the robot arrives at node nn.
It is guaranteed that there is only one node (node 1) whose in-degree is equal to 0,
and there is only one node (node n) whose out-degree is equal to 0. And there are no multiple edges in the graph.

Input
The first line contains one integer T (1≤T≤10)
For each case,the first line contains two integers n (2≤n≤10^5) and m (1≤m≤2×10^5), the number of nodes and the number of edges, respectively.
Each of the next mm lines contains two integers u and v (1≤u,v≤n) denoting a directed edge from u to v.
It is guarenteed that ∑n≤4×10^5, and ∑m≤5×10^5.

Output
Output T lines.Each line have a number denoting the expected durability consumption when the robot arrives at node n.
Please keep two decimal places.

样例输入
1
5 6
1 2
2 5
1 5
1 3
3 4
4 5
样例输出
9.78

题意

有n个点,1为起点,n为终点,起点入度为0,终点出度为0,保证起点终点唯一,每天可以选择转移到下一个点或者原地不动,每天的消耗为过去天数的总和,问你从起点到终点的期望天数是多少。

思路

期望dp

在这里插入图片描述
详细的状态转移方程可参照这个题解:https://blog.csdn.net/weixin_43847416/article/details/100318471

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define ll long long
using namespace std;
#define maxn 200005
double dp[maxn], dp2[maxn];
int n;
vector<int> G[maxn];

void init(){
	for(int i = 0; i <= n; i++){
		G[i].clear();
		dp[i] = 0;
		dp2[i] = 0;
	}
}

void dfs(int now){
    int i, j;
    int lim = G[now].size();
    double q = 1.0/(double)lim;
    for(i = 0; i < lim; i++){
        int v = G[now][i];
        if(!dp[v]&&(v!=n)) dfs(v);
        dp[now] += q*dp[v];
    }
    dp[now] += (1.0+q);
}

void dfs2(int now){
    int i, j;
    int lim = G[now].size();
    double q = 1.0/(double)lim;
    for(i = 0; i < lim; i++){
        int v = G[now][i];
        if(!dp2[v]&&(v!=n)) dfs2(v);
        dp2[now] += q*dp2[v];
    }
    dp2[now] += (1.0+q)*dp[now];
}

int main(){
    int i, j, m, k, T;
    int u, v;
    scanf("%d",&T);
    while(T--){
    	init();
        scanf("%d%d",&n,&m);
        for(i = 1; i <= m; i++){
            scanf("%d%d",&u,&v);
            G[u].push_back(v);
        }
        dfs(1);
        dfs2(1);
        printf("%.2f\n",dp2[1]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sure, I'd be happy to give you some ideas for organizing a speech contest. Here are some suggestions: 1. Determine the theme and rules: Decide on the theme of the contest and the rules for participants. Will it be an open topic, or will there be a specific theme? What is the maximum length of the speech? Will there be any specific guidelines for language or content? 2. Decide on the judging criteria: Determine how the speeches will be evaluated. Will judges be looking for content, delivery, or both? Will there be a score sheet or rubric that judges will use to score the speeches? 3. Recruit judges: Find people who are qualified to judge the speeches. Ideally, they should have experience in public speaking or have a background in the theme of the contest. 4. Promote the contest: Advertise the contest to potential participants, such as students, professionals, or members of a specific community. Use social media, flyers, and other methods to get the word out. 5. Registration and selection: Set a deadline for registration and selection of participants. Consider having a preliminary round to narrow down the field before the final competition. 6. Prepare the venue: Ensure that the venue is suitable for the contest. Make sure that there is adequate seating, sound equipment, and lighting for the speakers. 7. Hold the contest: Set a date and time for the contest, and make sure that all participants and judges are aware of the schedule. Encourage audience participation and provide refreshments. 8. Award ceremony: After the contest, hold an award ceremony to recognize the winners and participants. Provide certificates or other prizes to the top performers. I hope these ideas help you in organizing a successful speech contest!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值