状压DP:Islands and Bridges(POJ 2288)

**

状压DP:Islands and Bridges(POJ 2288)

**

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input

2 3
1 1 1
0 1 0
Sample Output

9
Hint

Number the squares as follows:
1 2 3
4

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意

n * m的土地里,1表示可种植地,0表示不可种植地,牛会在可种植地里吃玉米,但牛不喜欢挨在一起吃东西,问,有几种种植方法。不种植也算一种,无论种多少,只要

思路

不种植也算一种,无论种多少,只要满足条件就行。可用状压DP解决问题,1表示该位置上种,0表示不种。先预处理出一个数组state用来存放所有满足具有不相邻1的二进制数。而cnt表示每一行的不肥沃土地,则cnt&state如果为0的话,则表示该状态是符合所有条件的,再依次列举所有状态,符合就加上。

代码

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
#define mod (1000000000)
int dp[13][600];
int cnt[13], state[600];

int main(){
    int i, j, k, n, m,mx = 0;
    scanf("%d%d",&n,&m);
    for(i = 1;i <= n; i++){
        for(j = 0; j < m; j++){
            scanf("%d",&k);
            if(!k){
                cnt[i] |= (1<<j);
            }
        }
    }
    for(i = 0; i < (1<<m); i++){
        if(i&(i>>1) == 0) state[mx++] = i;
    }
    for(i = 0; i < mx; i++){
        if((cnt[1]&state[i]) == 0)
            dp[1][i] = 1;
    }
    for(i = 2; i <= n; i++){
        for(j = 0;j < mx; j++){
            if((state[j]&cnt[i])) continue;
            for(k = 0; k < mx; k++){
                if(cnt[i-1]&state[k]) continue;
                if(state[j]&state[k]) continue;
                dp[i][j] = (dp[i-1][k]+dp[i][j])%mod;
            }
        }
    }
    long long int ans = 0;
    for(i = 0; i < mx; i++) ans = (dp[n][i]+ans)%mod;
    printf("%I64d\n",ans);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值