POJ2342 Anniversary party(最简单的树形DP题)

**

POJ2342 Anniversary party

**

若有错误,烦请指出,不胜感激

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests’ ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

题意

给你一棵树,树上每个节点自带一个值,选取一部分节点,使这些节点的值和最大。若选取了一个节点,则不能选取他的父节点和子节点。(基本上所有讲树形DP的都将这题作为敲门砖。)

思路

先建图,建图时可以双向也可以单向,单向建图时,注意要判断一下哪个节点是根,可以在输入时,如下判断

for(i = 0; i <n; i++){
            scanf("%d%d",&x,&y);
            if(x==0&&y==0) continue;
            add_edge(y,x);
            if(!i) root = y;
            if(x == root) root = y;
        }

注意,输入时K是L的上级。
双向建图则需要在dp时判断一下父节点。
用dp[i][0]表示对于以i为根的子树来言,不选i时,可以获得的最大值。没选i,所以i的每个子节点可选可不选,用i_son表示i的子节点。
所以dp[i][0] = sum(max(dp[i_son][0],dp[i_son][1])).
dp[i][1]表示对于以i为根的子树来言,选i时,可以获得的最大值。因为选了i,所以i的每个子节点都不能选。
dp[i][1] = sum(dp[i_son][0]).
这样max(dp[root][0],dp[root][1])就是我们要求的最终状态。

代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 6001
struct Edge{
    int v, next;
}edge[maxn*2];
int cnt, n, head[maxn];
int dp[maxn][2],vis[maxn];
void add_edge(int u, int v){
    edge[cnt].v = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

void dfs(int now){
	vis[now] = 1;
    for(int i = head[now]; i != -1; i = edge[i].next){
    	int v = edge[i].v;
		if(vis[v]) continue;
        dfs(v);
        dp[now][1] += dp[v][0];
        dp[now][0] += max(dp[v][0], dp[v][1]);
    }
}

int main(){
    int i, j, k, x, y;
    while(scanf("%d",&n)!=EOF){
        cnt = 0;
        memset(head, -1, sizeof(head));
        memset(dp, 0, sizeof(dp));
        memset(vis, 0, sizeof(vis));
        for(i = 1; i <= n; i++) scanf("%d",&dp[i][1]);
        for(i = 0; i <n; i++){
            scanf("%d%d",&x,&y);
            if(x==0&&y==0) continue;
            add_edge(x,y); 
            add_edge(y,x);
        }
        dfs(1);
        printf("%d\n",max(dp[1][1],dp[1][0]));
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值