杭电OJ Robot Motion-1035

题目链接
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

思路:直接模拟就行了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
char direct[100][100], steps[100][100];
int vis[100][100];

int main()
{
    int row, col, ent;
    while(scanf("%d %d",&row,&col) && row){
        scanf("%d",&ent);
        map<char,int> p;
        char st;
        int step = 0, r = 0, c = ent - 1, flag = 0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i < row;i++){
            scanf("%s",direct[i]);
        }
        while(!vis[r][c]){
            step++;
            vis[r][c] = 1;
            steps[r][c] = step;
            switch(direct[r][c])
            {
                case 'N':
                    r -= 1;
                    break;
                case 'S':
                    r += 1;
                    break;
                case 'E':
                    c += 1;
                    break;
                case 'W':
                    c -= 1;
            }
            if((r >= row || r < 0) || (c >= col || c < 0)){
                flag = 1;
                break;
            }
        }
        if(!flag){
            printf("%d step(s) before a loop of %d step(s)\n",steps[r][c]-1,step-steps[r][c]+1);
        }
        else{
            printf("%d step(s) to exit\n",step);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值