Moo University - Financial Aid 优先队列+思维

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,“Moo U” for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1…2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university’s limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.

Input

  • Line 1: Three space-separated integers N, C, and F

  • Lines 2…C+1: Two space-separated integers per line. The first is the calf’s CSAT score; the second integer is the required amount of financial aid the calf needs
    Output

  • Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.
    Sample Input
    3 5 70
    30 25
    50 21
    20 20
    5 18
    35 30
    Sample Output
    35
    Hint
    Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.
    题目大意:从C头牛里选N头牛,每头牛有两个属性,得分score和经费aid,在总经费不超过F的情况下使得N头牛的得分中位数最大。

分析:先将C头牛按得分score升序,然后,我们假设每个i都可以作为中位数,lower[i]记录在i之前(也就是分数比它低)的总经费,upper[i]记录在i之后(也就是分数比它高)的总经费,最后,由于是求最大的中位数,所以,得分从后往前循环,第一个满足lower[i]+aid[i]+upper[i]的i就是最优解。

在求lower[i]和upper[i]的时候用优先队列把最大值弹出。

参考链接

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
#include <map>
#include <stack>
#include <queue>
using namespace std;
typedef long long ll;
const int MAX=0x3f3f3f3f;
const int N=111111;
pair<int,int> cow[N];
int lower[N],upper[N];
int main(){
	int n,c,f;
	cin>>n>>c>>f;
	for(int i=0;i<c;i++){
		cin>>cow[i].first>>cow[i].second;
	}
	int half=n/2;
	sort(cow,cow+c);
	int tot=0;
	priority_queue<int> q;
	for(int i=0;i<c;i++){
		if(q.size()==half){
			lower[i]=tot;
		}else{
			lower[i]=MAX;
		}
		q.push(cow[i].second);
		tot+=cow[i].second;
		if(q.size()>half){
			tot-=q.top();
			q.pop();
		}
	}
	while(!q.empty()) q.pop();
	tot=0;
	for(int i=c-1;i>=0;i--){
		if(q.size()==half){
			upper[i]=tot;
		}else{
			upper[i]=MAX;
		}
		q.push(cow[i].second);
		tot+=cow[i].second;
		if(q.size()>half){
			tot-=q.top();
			q.pop();
		}
	}
	while(!q.empty()) q.pop();
	int ans=-1;
	for(int i=c-1;i>=0;i--){                        //int i=c-1-half;i>=half;i--   也可以
		if(lower[i]+cow[i].second+upper[i]<=f){                
			ans=cow[i].first;
			break;
		}
	}
	cout<<ans<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值