L2-016 愿天下有情人都是失散多年的兄妹 (25 分)

呵呵。大家都知道五服以内不得通婚,即两个人最近的共同祖先如果在五代以内(即本人、父母、祖父母、曾祖父母、高祖父母)则不可通婚。本题就请你帮助一对有情人判断一下,他们究竟是否可以成婚?

输入格式:
输入第一行给出一个正整数N(2 ≤ N ≤10
​4
​​ ),随后N行,每行按以下格式给出一个人的信息:

本人ID 性别 父亲ID 母亲ID
其中ID是5位数字,每人不同;性别M代表男性、F代表女性。如果某人的父亲或母亲已经不可考,则相应的ID位置上标记为-1。

接下来给出一个正整数K,随后K行,每行给出一对有情人的ID,其间以空格分隔。

注意:题目保证两个人是同辈,每人只有一个性别,并且血缘关系网中没有乱伦或隔辈成婚的情况。

输出格式:
对每一对有情人,判断他们的关系是否可以通婚:如果两人是同性,输出Never Mind;如果是异性并且关系出了五服,输出Yes;如果异性关系未出五服,输出No。

输入样例:
24
00001 M 01111 -1
00002 F 02222 03333
00003 M 02222 03333
00004 F 04444 03333
00005 M 04444 05555
00006 F 04444 05555
00007 F 06666 07777
00008 M 06666 07777
00009 M 00001 00002
00010 M 00003 00006
00011 F 00005 00007
00012 F 00008 08888
00013 F 00009 00011
00014 M 00010 09999
00015 M 00010 09999
00016 M 10000 00012
00017 F -1 00012
00018 F 11000 00013
00019 F 11100 00018
00020 F 00015 11110
00021 M 11100 00020
00022 M 00016 -1
00023 M 10012 00017
00024 M 00022 10013
9
00021 00024
00019 00024
00011 00012
00022 00018
00001 00004
00013 00016
00017 00015
00019 00021
00010 00011
输出样例:
Never Mind
Yes
Never Mind
No
Yes
No
Yes
No
No

注意点:
夫妻双方爸妈都找。

解答:

#include <cstdio>
#include <algorithm>
#include <vector>
#define foreach(a,b,c) for((a)=(b); (a)<(c); (a)++)

using namespace std;

class People{

public:
	int id,father,mother;
	char sex;

public:
	People(){
		this->id = -1;
		this->sex = 'F';
		this->father = -1;
		this->mother = -1;
	}

	People(int id,char sex,int father,int mother){
		this->id = id;
		this->sex = sex;
		this->father = father;
		this->mother = mother;
	}

};

int i,j,t,N,K,id,father,mother,a_id,b_id;
char sex;
People* people[100000];
vector<int> ergodic;
vector<int>::iterator it;

bool canMarry(int times);

int main(){
	scanf("%d",&N);
	foreach(i,0,N){
		scanf("%d %c %d %d",&id,&sex,&father,&mother);
		people[id] = new People(id,sex,father,mother);

		if(father!=-1 && people[father]==NULL){
			people[father] = new People();
			people[father]->id = father;
			people[father]->sex = 'M';
		}
		if(mother!=-1 && people[mother]==NULL){
			people[mother] = new People();
			people[mother]->id = mother;
		}

	}
	scanf("%d",&K);
	foreach(i,0,K){
		scanf("%d %d",&a_id,&b_id);

		if(people[a_id]->sex == people[b_id]->sex){
			printf("Never Mind\n");
			continue;
		}

		if(people[a_id]->father!=-1)
			ergodic.push_back(people[a_id]->father);
		if(people[b_id]->father!=-1)
			ergodic.push_back(people[b_id]->father);
		if(people[a_id]->mother!=-1)
			ergodic.push_back(people[a_id]->mother);
		if(people[b_id]->mother!=-1)
			ergodic.push_back(people[b_id]->mother);

		if(canMarry(1)){
			printf("Yes\n");
		}else{
			printf("No\n");
		}

		ergodic.clear();
	}
	return 0;
}

bool canMarry(int times){
	if(times==5){
		return true;
	}
	if(ergodic.empty()){
		return true;
	}
	bool flag = false;
	int len = ergodic.size(),peo;

	foreach(j,0,len-1){
		foreach(t,j+1,len){
			if(ergodic[j]==ergodic[t]){
				flag = true;
				j = len;
				break;
			}
		}
	}

	if(flag){
		return false;
	}

	foreach(j,0,len){
		peo = ergodic[0];
		if(people[peo]->father!=-1)
			ergodic.push_back(people[peo]->father);
		if(people[peo]->mother!=-1)
			ergodic.push_back(people[peo]->mother);
		ergodic.erase(ergodic.begin());
	}
	return canMarry(times+1);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值