海岛与雷达

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. Figure A Sample Input of RadarnInstallations

input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. The input is terminated by a line containing pair of zeros 

output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

题意:有一条海岸线海岸线将陆地与海洋分开,在海洋里有若干个海岛,现在在海岸线上设立雷达装置,所有的雷达都有相同的检测范围。为使得每个海岛都能被检测到,求所需要的做少雷达数量。如果海岛距离海岸线的距离超过雷达检测的距离,则输出-1。

输入第一行m,n,m表示有几个海岛,n表示雷达检测的距离。下面的m行输入m个海岛的坐标点。

输出最少需要的雷达数。

题目分析:第一次做这个题的时候,想了很长时间,完全没有思路,查了一下,看到了这种题可以利用作一个圆形来解决,自己想了下,就有点思路了。

可以以每个海岛为圆点,雷达检测的距离为半径,做一个圆,找出他与x轴的交点坐标,再利用这些交点坐标,利用坐标的大小,判断是否存在x轴上存在满足条件的点,即雷达的数量。

 

代码实现

#include <iostream>
#include <algorithm>
#include <queue>
#include <cmath>
#include <cstdio>
using namespace std;
struct island{
	int x,y;
	double begin,end;
}a[1000];
bool cmp(island a,island b){
	return a.end<b.end;
}
int main()
{
	int m,n;
	double len;
	int cishu = 0;
	while(cin>>m>>n){
		if(m==0&&n==0)
			break;
		int flag = 1;
		cishu++;
		for(int i = 0;i<m;i++){
			cin>>a[i].x>>a[i].y;
			if(a[i].y>n)
				flag = 0;
			if(a[i].y==n)
				a[i].begin = a[i].end = a[i].x;
			if(a[i].y<n){
				len = sqrt(1.0*n*n-a[i].y*a[i].y);
				a[i].begin = a[i].x-len;
				a[i].end = a[i].x+len;
			}
		}
		sort(a,a+m,cmp);
		int sum = 1;
		double p = a[0].end;
		for(int i = 1;i<m;i++){
			if(p<a[i].begin){
				sum++;
				p = a[i].end;
			}
		}
		if(flag==0){
			printf("Case %d: -1\n",cishu);
			
		}
		else{
			printf("Case %d: %d\n",cishu,sum);
		}
		/*if(flag==0)
		cout<<"Case "<<": "<<-1<<endl;
		else
		cout<<"Case "<<cishu<<": "<<sum<<endl;*/
	}
	return 0;
}



 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值