poj1094 Sorting It All Out(拓扑排序)

Sorting It All Out

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 42094 Accepted: 14742

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

East Central North America 2001

 

#include <iostream>
#include <string.h>
#include <vector>
#include <queue>
using namespace std;
const int INF = 99999999;
int ind[100];
int G[105][105];
int flag;
int n,m;
int ans[105];
int topo(){
    flag = 1;
    int num = 0;
    queue<int> Q;
    int tempd[100];
    for(int i = 1;i <= n;i++){
        tempd[i] = ind[i];
    }
    for(int i = 1;i <= n;i++){
        if(tempd[i] == 0){
            Q.push(i);
        }
    }
    while(!Q.empty()){
        if(Q.size() > 1){
            flag = 3;
            //break;
        }
        int u = Q.front();
        Q.pop();
        ans[++num] = u;
        for(int i = 1;i <= n;i++){
            int v = G[u][i];
            if(v != 0){
                tempd[i]--;
                if(tempd[i] == 0){
                    Q.push(i);
                }
            }
        }
    }
    //cout << num << endl;
    if(flag == 3 && num == n){
        //flag = 2;
        return 3;
    }
    else if(num != n){
        return 2;
    }
    else{
        //flag = 1;
        return 1;
    }
}

int main()
{
    while(cin >> n >> m){
        if(n == 0 && m == 0) break;
        bool tempflag1 = true;
        bool tempflag2 = true;
        memset(ind,0,sizeof(ind));
        memset(G,0,sizeof(G));
        for(int i = 1;i <= m;i++){
            char a,b,c;
            cin >> a >> b >> c;
            if(tempflag1 && tempflag2){
                int x = a - 'A' + 1;
                int y = c - 'A' + 1;
                if(G[x][y] == 1){
                    cout << "Inconsistency found after "<<i<<" relations."<<endl;
                    tempflag2 = false;
                    continue;
                }

                if(G[y][x] == 0){
                    G[y][x] = 1;
                    ind[x]++;
                }
                //cout << n << " " << m << endl;
                int k = topo();
                if(k == 1){
                    cout << "Sorted sequence determined after " << i << " relations: ";
                    for(int j = n;j >= 1;j--){
                        cout << char(ans[j] + 'A' - 1);
                    }
                    cout << "." << endl;
                    tempflag1 = false;
                }
                else if(k == 2){
                    cout << "Inconsistency found after "<<i<<" relations."<<endl;
                    tempflag2 = false;
                }
            }
        }
        if(tempflag1 && tempflag2){
            cout << "Sorted sequence cannot be determined." << endl;
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值