POJ 3268 Silver Cow Party (dijkstra+矩阵转置)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

 

注意:输入!=EOF ,不然会输出超时。由于是单向边,转置前是起点到各点的最短距离,转置后再来一次dijkstra相当于各点到起点 的最短距离。然后取两次和的最大值即可。用转置是为了将复杂度

#include <iostream>
#include <algorithm>
#include <math.h>
#include <vector>
#include<cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <string.h>
#include<bitset>
typedef long long ll;

using namespace std;
const int   inf=0x3f3f3f3f;
//int inf  = 2e7+100;


int n,m,s;
int   G[2222][2222];
int vis[1111],d[1111],p[1111];

void dij()
{
    for(int i=1;i<=n;i++)
    {
        vis[i]=0;
        d[i]=G[s][i];
    }
    d[s]=0;
    for(int i=1;i<=n;i++)
    {
        int u=-1,mi=inf;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]<mi)
            {
                mi=d[j];
                u=j;
            }
        }
        if(u==-1)
            break;
        vis[u]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]>d[u]+G[u][j])
                d[j]=d[u]+G[u][j];
        }
    }
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
             G[i][j]=i==j?0:inf;
        for(int i=1;i<=m;i++)
        {
            int a ,b,c;
            scanf("%d%d%d",&a,&b,&c);
           if(c<G[a][b])
                G[a][b]=c;
        }

        dij(); //  cout<<1<<endl;

        memcpy(p,d,sizeof(d));
       // for(int i=1;i<=n;i++)
           // cout<<p[i]<<' ';
        //cout<<endl;
        for(int i=1;i<=n;i++)
            for(int j=i+1;j<=n;j++)
        {
            int t=G[i][j];
            G[i][j]=G[j][i];
            G[j][i]=t;
        }
        dij();
        //for(int i=1;i<=n;i++)
            //cout<<d[i]<<' ';
        //cout<<endl;
        int ans=-1;
        for(int i=1;i<=n;i++)
        {
            if(i!=s)
               ans=max(ans,d[i]+p[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵幂序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速幂 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次幂矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速幂,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值