Monthly Expense (二分初级典例)

 

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:给你n个数,让分成m组,每组必须是连续的几个数,求所有组的和的最大值的最小值。

思路:二分枚举答案。从low(n天中一天的最大花费,理论的最小值)到high(n天的总花费),寻找一个数,检查是否符合题意(以这个数为最大花费,所得最少组数小于m,且low等于high)。用二分就是加快寻找这个数的速度,例如在100内寻找一个数,用遍历的方法平均复杂度是50,用二分就是log2 100,范围越大,二分的速度优势更明显。

#include<iostream>
#include<cmath>
#include<stdio.h>
using namespace std;

int n,m;
int a[100002];
bool find(int top){   //检查解是否在mid和low之间
	int num=1;
	int cur=0;
	for(int i=0;i<n;i++)
	{
		if(cur+a[i]<=top)
			cur+=a[i];//归入同意组
		else
		{
			num++;    //新的一组
			cur=a[i];
		}
	}
	return (num<=m);
}

int main()
{
 while(cin>>n>>m)
 {
 	int sum=0;
 	int maxx=0;
 	for(int i=0;i<n;i++)
 	{
 		cin>>a[i];
 		sum+=a[i];
 		maxx=max(maxx,a[i]);
 	}
 	int low=maxx,high=sum,mid;//初始化上下界
 	while(low!=high)
 	{
 		mid=(high+low)/2;  //二分
 		if(find(mid))
 			high=mid;
 		else
 			low=mid;
 	}
 	cout<<low<<endl;
 }
 return 0;
}

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值