POJ3263 Tallest Cow差分模板练习

POJ3263

FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1…N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1…N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Sample Input
9 3 5 5
1 3
5 3
4 3
3 7
9 8
Sample Output
5
4
5
3
4
4
5
5
5

题意:有n头牛站成一行。如果两头牛之间的牛都比他们俩矮,那么这两头牛才可以互相看见。我们只知道第P头牛是最高的,高H。我们还知道M对关系,代表 A i A_i Ai 与 B i 与B_i Bi这两头牛可以相互看见。求每头牛最大可能身高。

题解:
差分,建立一个数组 D D D D i D_i Di代表从i开始有一个作用到最后,如果想要令这个作用只持续一段区间比如说[i, j],那么从 D j + 1 D_{j+1} Dj+1开始加上一个反作用即可。

复杂度 O ( n + m ) O(n + m) O(n+m)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;
typedef long long ll;

map<pair<int, int>, bool> existed;
int c[10010], d[10010];

int main(){
	int n, p, h, m;
	cin >> n >> p >> h >> m;
	for (int i = 1; i <= m; i++){
		int a, b;
		scanf("%d%d", &a, &b);
		if (a > b) swap(a, b);
		if(existed[make_pair(a, b)]) continue;
		d[a + 1]--, d[b]++, existed[make_pair(a, b)] = true;
	}
	for(int i = 1; i<= n; i++){
		c[i] = c[i - 1] + d[i];
		printf("%d\n", h + c[i]);
	}
	cout << endl;	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值