Tallest Cow(前缀差分)

Tallest Cow(前缀差分)

题目描述

FJ’s N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.
FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form “cow 17 sees cow 34”. This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.
For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

输入

Line 1: Four space-separated integers: N, I, H and R 
Lines 2..R+1: Two distinct space-separated integers A and B (1 ≤ A, B ≤ N), indicating that cow A can see cow B.

输出

Lines 1..N: Line i contains the maximum possible height of cow i.

样例输入

复制样例数据

9 3 5 5
1 3
5 3
4 3
3 7
9 8
样例输出
5
4
5
3
4
4
5
5
5

ps:差分加前缀和


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
#include <iostream>

#include <set>

const int N = 1e5+10;

using namespace std;

int n,p,h,m;

int he[N];

int main()

{

    std::ios::sync_with_stdio(false);

    cin>>n>>p>>h>>m;

    he[1]=h;//后面前缀和用得着

    set<pair<int,int> >vis;//去重

    while(m--){

        int x,y;

        cin>>x>>y;

        if(x>y) {

            int t=x;

            x=y;

            y=t;

        }

        if(!vis.count({x,y})){

            vis.insert({x,y});//把之间的牛的高度减一

            he[x+1]--;

            he[y]++;

        }

    }

    for(int i=1;i<=n;i++){//求前缀和

        he[i]=he[i-1]+he[i];

        cout<<he[i]<<endl;

    }

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值