【紫书】UVa-401 A - Palindromes(字符串处理)

A regular palindrome is a string of numbers or letters that is the
same forward as backward. For example, the string “ABCDEDCBA” is a
palindrome because it is the same when the string is read from left to
right as when the string is read from right to left. A mirrored string
is a string for which when each of the elements of the string is
changed to its reverse (if it has a reverse) and the string is read
backwards the result is the same as the original string. For example,
the string “3AIAE” is a mirrored string because ‘A’ and ‘I’ are their
own reverses, and ‘3’ and ‘E’ are each others’ reverses. A mirrored
palindrome is a string that meets the criteria of a regular palindrome
and the criteria of a mirrored string. The string “ATOYOTA” is a
mirrored palindrome because if the string is read backwards, the
string is the same as the original and because if each of the
characters is replaced by its reverse and the result is read
backwards, the result is the same as the original string. Of course,
‘A’, ‘T’, ‘O’, and ‘Y’ are all their own reverses. A list of all valid
characters and their reverses is as follows. Character Reverse
Character Reverse Character Reverse A A M M Y Y B N Z 5 C O O 1 1 D P
2 S E 3 Q 3 E F R 4 G S 2 5 Z H H T T 6 I I U U 7 J L V V 8 8 K W W 9
L J X X Note that ‘0’ (zero) and ‘O’ (the letter) are considered the
same character and therefore ONLY the letter ‘O’ is a valid character.
Input Input consists of strings (one per line) each of which will
consist of one to twenty valid characters. There will be no invalid
characters in any of the strings. Your program should read to the end
of file. Output For each input string, you should print the string
starting in column 1 immediately followed by exactly one of the
following strings. STRING CRITERIA ‘ – is not a palindrome.’ if the
string is not a palindrome and is not a mirrored string ‘ – is a
regular palindrome.’ if the string is a palindrome and is not a
mirrored string ‘ – is a mirrored string.’ if the string is not a
palindrome and is a mirrored string ‘ – is a mirrored palindrome.’ if
the string is a palindrome and is a mirrored string Note that the
output line is to include the ‘-’s and spacing exactly as shown in the
table above and demonstrated in the Sample Output below. In addition,
after each output line, you must print an empty line. Sample Input
NOTAPALINDROME ISAPALINILAPASI 2A3MEAS ATOYOTA Sample Output
NOTAPALINDROME – is not a palindrome. ISAPALINILAPASI – is a regular
palindrome. 2A3MEAS – is a mirrored string. ATOYOTA – is a mirrored
palindrome.

题目的意思的大概意思就是判断字符串是否为回文串或者镜像串,这里给出书里思路的代码

#include <bits/stdc++.h>
#define N 100
using namespace std;
char miroralpha[] = "A   3  HIL JM O   2TUVWXY5";
char mirordigit[] = "1SE Z  8 ";
char *msg[] = {" -- is not a palindrome."
               , " -- is a regular palindrome."
               , " -- is a mirrored string."
               , " -- is a mirrored palindrome."};
 

char miror(char c)
{
    if(isalpha(c))
        return miroralpha[c - 'A'];
    else
        return mirordigit[c - '1'];
}
 
//计算字符串类型
int gettype(char s[])
{
    int start, end, p, m;
 
    p = 1;  
    m = 1;  
 
    start = 0;
    end = strlen(s)-1;
    while(start <= end) {
        if(s[start] != s[end])
            p = 0;
        if(miror(s[start]) != s[end])
            m = 0;
        start++;
        end--;
    }
 
    return m * 2 + p;
}
 
int main()
{
    char s[N];
 
    while(scanf("%s", s) == 1)
        printf("%s%s\n\n", s, msg[gettype(s)]);
 
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值