【紫书】UVa 1592 Database(map )(字符串哈希 +排序(暂时空缺))

Peter studies the theory of relational databases. Table in the relational database consists of values that
are arranged in rows and columns.
There are different normal forms that database may adhere to. Normal forms are designed to
minimize the redundancy of data in the database. For example, a database table for a library might
have a row for each book and columns for book name, book author, and author’s email.
If the same author wrote several books, then this representation is clearly redundant. To formally
define this kind of redundancy Peter has introduced his own normal form. A table is in Peter’s Normal
Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the
corresponding columns are the same for both rows.
How to compete in ACM ICPC Peter peter@neerc.ifmo.ru
How to win ACM ICPC Michael michael@neerc.ifmo.ru
Notes from ACM ICPC champion Michael michael@neerc.ifmo.ru
The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and
3rd rows. However, if we introduce unique author identifier and split this table into two tables — one
containing book name and author id, and the other containing book id, author name, and author email,
then both resulting tables will be in PNF.
How to compete in ACM ICPC 1
How to win ACM ICPC 2
Notes from ACM ICPC champion 2
1 Peter peter@neerc.ifmo.ru
2 Michael michael@neerc.ifmo.ru
Given a table your task is to figure out whether it is in PNF or not.
Input
Input contains several datasets. The first line of each dataset contains two integer numbers n and m
(1 ≤ n ≤ 10000, 1 ≤ m ≤ 10), the number of rows and columns in the table. The following n lines
contain table rows. Each row has m column values separated by commas. Column values consist of
ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma
(ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most
80 characters (including separating commas).
Output
For each dataset, if the table is in PNF write to the output file a single word “YES” (without quotes).
If the table is not in PNF, then write three lines. On the first line write a single word “NO” (without
quotes). On the second line write two integer row numbers r1 and r2 (1 ≤ r1, r2 ≤ n, r1 ̸= r2), on
the third line write two integer column numbers c1 and c2 (1 ≤ c1, c2 ≤ m, c1 ̸= c2), so that values in
columns c1 and c2 are the same in rows r1 and r2.
Sample Input
3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru
Sample Output
NO
2 3
2 3
YES

用map写的,有点不太熟练,哈希以后补

#include<bits/stdc++.h>
using namespace std;
typedef pair<string,string> PII;
map<PII,int> die;
const int N = 10001;
PII t;
int Id=0;

int judge(int n)
{
	if(!die.count(t)){
		die[t]=n;
		return -1;
	}
	else{
		return die[t];
	}
}

int main()
{
	int m,n;
	
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		string data[N][10];
		//读取
		for(int i=0;i<n;i++){
			int d=0;
			string s;
			getline(cin,s);
				for(int j=0;j<s.length();j++){
					data[i][d].push_back(s[j]);
					if(s[j]==','){
						data[i][d].push_back(s[j]);
						d++;
					}
				} 				
			
		}
		int flag=0;
		for(int i=0;i<m;i++){
			for(int j=i+1;j<m;j++){
				die.clear();
				
				for(int k=0;k<n;k++){
					t.first=data[k][i];
					t.second=data[k][j];
					int ans=judge(k);
					if(ans!=-1){
						puts("NO");
						printf("%d %d\n",ans+1,j+1);
						printf("%d %d\n",i+1,j+1);
						flag=1;
						break;
					}
					if(flag) break;
				}
			}
		}
		if(!flag)
		printf("YES\n");
		
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值