HDU - 2612:Find a way(BFS)

原题链接
Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input
4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#

Sample Output
66
88
66

题目描述

Y、M到达同一家I@,求两者路程之和最短所需的时间(每走一步,需要11分钟),.可以走、#不可以走

思路:对Y、M分别广度搜索,对于不同的@记录Y、M到达的路程之和,最后输出路程最短的时间

代码如下

#include <stdio.h>
#include <algorithm>
#include <queue>
#include <string.h>
#define N 205
using namespace std;

struct node
{
    int x,y,step;
};
int n,m,dis[N][N],book[N][N];
char Map[N][N];
int oper[4][2] = {
    {1, 0},
    {0, 1},
    {-1, 0},
    {0, -1}
};

void bfs(int x, int y)
{
    queue<node> q;
    int i,j;
    node now;
    now.x = x;
    now.y = y;
    now.step = 0;
    q.push(now);
    while(!q.empty())
    {
        node next;
        now = q.front();
        q.pop();
        next.step = now.step + 1;
        for(i = 0;i < 4;i++)
        {
            next.x = now.x + oper[i][0];
            next.y = now.y + oper[i][1];
            if(Map[next.x][next.y] == '#' || next.x < 0 || next.x >= n || next.y < 0 || next.y >= m)
                continue;
            if(!book[next.x][next.y])
            {
                book[next.x][next.y] = 1;
                dis[next.x][next.y] += next.step;	//分别记录到达某个点的路程之和
                q.push(next);
            }
        }
    }
}

int main()
{
    int i,j;
    while(~scanf("%d %d",&n,&m))
    {
        int mins = 500;
        memset(dis, 0, sizeof(dis));
        memset(Map, 0, sizeof(Map));
        for(i = 0;i < n;i++)
            scanf("%s",Map[i]);
        for(i = 0;i < n;i++)
        {
            for(j = 0;j < m;j++)
            {
                if(Map[i][j] == 'Y' || Map[i][j] == 'M')
                {
                    memset(book, 0, sizeof(book));
                    bfs(i, j);
                }
            }
        }
        for(i = 0;i < n;i++)
        {
            for(j = 0;j < m;j++)
            {
                if(Map[i][j] == '@' && dis[i][j] < mins && dis[i][j] != 0)
                {
                    mins = dis[i][j];
                }
            }
        }
        printf("%d\n",mins*11);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值