HDU 1969 Pie

题目描述:

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

思路分析:直接暴力二分搜索合适的体积。。。每一块饼其实分的是底面积,最终乘以Π即可。

注意:没想到还会在Π的精确度上设陷阱!!!少于12位就会WA!!!

 

#include <stdlib.h>
#include <stdio.h>
#include <iostream>
#include <queue>
#include <algorithm>
#include <string.h>

#define pi 3.14159265359

using namespace std;

int t,n,f;
int a[10010];

bool cmp(int a,int b){
    return a>b;
}

int check(double x){    //检查以x为尺寸,能分出几块饼来
    int total=0;
    for(int i=0;i<n;i++){
        double t=a[i];
        while(t>=x){   //当t<x时,不能分出完整一块,扔掉
            total++;
            t-=x;
        }
    }
    if(total>=f) return 1;
    else return 0;
}

int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&f);
        f++;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            a[i]*=a[i];
        }

        double left=0,right=100000000;
        double mid;
        double Max_mid=0;
        while(right-left>1e-6){
            mid=(left+right)/2.0;
            if(check(mid)){
                Max_mid=mid;
                left=mid;
            }
            else right=mid;
            //printf("%f %f %f\n",left,mid,right);
        }
        printf("%.4f\n",Max_mid*pi);
    }
}

 

一开始还想分情况讨论,后来发现想错了。按照下面的思路,如果例子中的饼是10,1,1,1,分给三个人,会得到错误答案

WA代码

#include <stdlib.h>
#include <stdio.h>
#include <iostream>
#include <queue>
#include <algorithm>
#include <string.h>

#define pi 3.141592

using namespace std;

int t,n,f;
int a[10010];

bool cmp(int a,int b){
    return a>b;
}

int check(double x){
    int total=0;
    for(int i=0;i<n;i++){
        double t=a[i];
        while(t>=x){
            total++;
            t-=x;
        }
    }
    if(total>=f) return 1;
    else return 0;
}

int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&f);
        f++;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            a[i]*=a[i];
        }
        sort(a,a+n,cmp);
        if(n>=f){
            printf("%.4f\n",pi*a[f-1]);
        }
        else {
            double left=0,right=a[0];
            double mid;
            double Max_mid=0;
            while(right-left>1e-6){
                mid=(left+right)/2.0;
                if(check(mid)){
                    Max_mid=mid;
                    left=mid;
                }
                else right=mid;
                //printf("%f %f %f\n",left,mid,right);
            }
            printf("%.4f\n",Max_mid*pi);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
该资源内项目源码是个人的课程设计、毕业设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。 该资源内项目源码是个人的课程设计,代码都测试ok,都是运行成功后才上传资源,答辩评审平均分达到96分,放心下载使用! ## 项目备注 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用! 2、本项目适合计算机相关专业(如计科、人工智能、通信工程、自动化、电子信息等)的在校学生、老师或者企业员工下载学习,也适合小白学习进阶,当然也可作为毕设项目、课程设计、作业、项目初期立项演示等。 3、如果基础还行,也可在此代码基础上进行修改,以实现其他功能,也可用于毕设、课设、作业等。 下载后请首先打开README.md文件(如有),仅供学习参考, 切勿用于商业用途。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值