Wave

Wave

Avin is studying series. A series is called "wave" if the following conditions are satisfied:
1) It contains at least two elements;
2) All elements at odd positions are the same;
3) All elements at even positions are the same;
4) Elements at odd positions are NOT the same as the elements at even positions.
You are given a series with length n. Avin asks you to find the longest "wave" subseries. A subseries is a subsequence of a series.

Input

The first line contains two numbers n, c (1 ≤ n ≤ 100, 000, 1 ≤ c ≤ 100). The second line contains n integers whose range is [1, c], which represents the series. It is guaranteed that there is always a "wave" subseries.

Output

Print the length of the longest "wave" subseries.

Sample Input

5 3
1 2 1 3 2

Sample Output

4
#include<bits/stdc++.h>

using namespace std;

vector<int> V[105];
int main()
{
	int n, m, a, ans = 0;
	cin >> n >> m;
	for( int i = 1; i <= n; i++){
		cin >> a;
		V[a].push_back(i);
	}
	for( int i = 1; i <= m; i++)
	for( int j = 1; j <= m; j++){
		if( i == j ) continue;
		int  size1 = V[i].size(), size2 = V[j].size();
		int  x = 0, y = 0, now = 0, sum = 0;
		while( true ){
			while( V[i][x] < now && x < size1 ) x++; now = V[i][x]; 
			if( x == size1 ) break; 
			sum++;
			while( V[j][y] < now && y < size2 ) y++; now = V[j][y];
			if( y == size2 ) break;
			sum++;
		}
		ans = max( ans, sum );
	}
	cout << ans << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值