Avin is studying series. A series is called "wave" if the following conditions are satisfied:
1) It contains at least two elements;
2) All elements at odd positions are the same;
3) All elements at even positions are the same;
4) Elements at odd positions are NOT the same as the elements at even positions.
You are given a series with length n. Avin asks you to find the longest "wave" subseries. A subseries is a subsequence of a series.
Input
The first line contains two numbers n, c (1 ≤ n ≤ 100, 000, 1 ≤ c ≤ 100). The second line contains n integers whose range is [1, c], which represents the series. It is guaranteed that there is always a "wave" subseries.
Output
Print the length of the longest "wave" subseries.
Sample Input
5 3 1 2 1 3 2
Sample Output
4
把x出现过的坐标存起来,
枚举1~c 的两个数,x,y
比较他们的出现过得坐标,使得相交长度最长
例如:
x: 1 3 4 5 7 8
y:2 4 6 9
最长的就是 x1 y2 x3 y4 x5 y6 x7 y9
#include<bits/stdc++.h>
using namespace std;
vector<int> V[105];
int main()
{
int n, m, x, ans = 0;
cin >> n >> m;
for( int i = 1; i <= n; i++)
{
cin >> x;
V[x].push_back(i); //x出现过的坐标放进去
}
for( int i = 1; i <= m; i++)
for( int j = 1; j <= m; j++)
{
if( i == j ) continue;
int size1 = V[i].size(), size2 = V[j].size();
int x1 = 0, x2 = 0, now = 0, sum = 0;
while( true )
{
while( V[i][x1] < now && x1 < size1 ) x1++; now = V[i][x1];//找到第一个比当前坐标大的
if( x1 == size1 ) break; //如果到底了 跳出
sum++; //找到一个加一个
while( V[j][x2] < now && x2 < size2 ) x2++; now = V[j][x2];
if( x2 == size2 ) break;
sum++;
}
ans = max( ans, sum );
}
cout << ans << endl;
return 0;
}