hdu 1116 Play on Words

Problem Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm'' can be followed by the wordmotorola’’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题目大意为 给定几个盘子 无序 要求连成收尾连接的 比如第二组 a->m->m->m->e;
可以构成则可以 。

#include<cstdio>
#include<cstring> 
using namespace std;
bool a[26][26],vis[26];
int in[26],out[26],t,n;
char s[10001];
bool judge1()//用来检查是否全部连接  这个也可以用并查集 ,(判断几个祖节点) 可能并查集更快些
{
    int i,j,k;
    for(k=0;k<26;k++)
      for(i=0;i<26;i++)
        for(j=0;j<26;j++)
          if(a[i][k]&&a[k][j])
            a[i][j]=a[j][i]=1;//将所有的都连接起来
    for(i=0;i<26;i++)
      if(vis[i])
        for(j=0;j<26;j++)
          if(vis[j])
            if(!a[i][j])
              return 0;
    return 1;
}
bool judge2()//欧拉回路 有向图的判断,入度等于出度。最多且仅可能存在一组的1与-1(起始点)
{
    int i,j=0,k=0;
    bool flag=1;
    for(i=0;i<26;i++)
      if(vis[i])
      {
          if(in[i]-out[i]==1)
          {
              flag=0;
              j++;
        }
        else
          if(out[i]-in[i]==1)
          {
              flag=0;
              k++;
          }
          else
            if(in[i]!=out[i])
              return 0;
      }
    if(flag)
      return 1;
    if(j==1&&k==1)
      return 1;
    return 0;
}
int main()
{
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%s",&s);
            int x=s[0]-'a',y=s[strlen(s)-1]-'a';
            a[x][y]=a[y][x]=1;
            out[x]++;
            in[y]++;
            vis[x]=vis[y]=1;
        }
        if(judge1()&&judge2())
          printf("Ordering is possible.\n");
        else
          printf("The door cannot be opened.\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值