Bored Three-God (大数加法)

The bored Three-God get another boring question. 

This problem is ask you plus two big nubmer, please help him, when you solve this problem you can

speak to Three-God,"Oh, Please give me a diffculte one, this one is too easy".

Input

There are muti-case 
For each case, there are two integers, n, m (0 < n, m < 10^10000).

Output

Calculate two integers' sum

Sample Input

1 1
2 3
10000 100000

Sample Output

2
5
110000

题意 给两数 输出和 就是大数加法 

因为数据小就直接暴力了,输入貌似会有前导0,输出也要前导0;本来写了超时了 再看才发现scanf前没加‘~’,要仔细= =

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
char a[10005];
char b[10005];
int c[10005];
int d[10005];
int e[10005];
int main()
{
    while(~scanf("%s %s",a,b))
    {
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        memset(e,0,sizeof(e));
        int la=strlen(a);
        int lb=strlen(b);
        int lc=max(la,lb);
        for(int i=0;i<la;i++)
            c[i]=a[la-1-i]-'0';
        for(int i=0;i<lb;i++)
            d[i]=b[lb-1-i]-'0';
            int k=0;
        for(int i=0;i<lc;i++)
        {
            e[i]=c[i]+d[i]+k;
                k=e[i]/10;
                e[i]=e[i]%10;
        }
        if(k)
        {
            e[lc]=k;
            lc++;
        }
        for(int i=lc-1;i>=0;i--)
        {
            printf("%d",e[i]);
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值