Time (字符模拟数字)

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.

Input

There are several test cases. 
Each case contains 4 integers in a line, separated by space. 
Proceed to the end of file.

Output

For each test case, output the time expressed by the digital clock such as Sample Output.

Sample Input

1 2 5 6
2 3 4 2

Sample Output

    _  _  _ 
  | _||_ |_ 
  ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

Hint

The digits showed by the digital clock are as follows:
   _  _     _  _  _  _  _  _ 
 | _| _||_||_ |_   ||_||_|| |
 ||_  _|  | _||_|  ||_| _||_|

题意 数字钟用4位数字表示时间,每个数字用3*3个字符表示,现在给定当前时间,请告诉我们数字钟如何表示。

输入4个数字 输出用字符组成的形状

复制提示存起来 在输出就好了 把0忘了就过不了了

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char a1[35]= {"    _  _     _  _  _  _  _  _ "};
char a2[35]= {"  | _| _||_||_ |_   ||_||_|| |"};
char a3[35]= {"  ||_  _|  | _||_|  ||_| _||_|"};
void re(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a1[i]);
        }
    }
    else
        printf(" _ ");
    return ;
}
void r2(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a2[i]);
        }
    }

    else
        printf("| |");
}
void r3(int a)
{
    if(a!=0)
    {
        for(int i=(a-1)*3; i<3+(a-1)*3; i++)
        {
            printf("%c",a3[i]);
        }
    }

    else
        printf("|_|");
}
int main()
{
    int a,b,c,d;
    while(~scanf("%d %d %d %d",&a,&b,&c,&d))
    {
        re(a);
        re(b);
        re(c);
        re(d);
        printf("\n");
        r2(a);
        r2(b);
        r2(c);
        r2(d);
        printf("\n");
        r3(a);
        r3(b);
        r3(c);
        r3(d);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值