UVa 10929 - You can say 11

经过几十次的WA终于A了;

escription

Your job is, given a positive number N, determine if it is a multiple of eleven.
Input specification
The input is a file such that each line contains a positive number. A line containing the number 0 is the end of the input. The given numbers can contain up to 1000 digits.
Output specification
The output of the program shall indicate, for each input number, if it is a multiple of eleven or not.

Sample input

112233
30800
2937
323455693
5038297
112234
0

Sample output

112233 is a multiple of 11.
30800 is a multiple of 11.
2937 is a multiple of 11.
323455693 is a multiple of 11.
5038297 is a multiple of 11.
112234 is not a multiple of 11.

#include <iostream>

using namespace std;
#include <bits/stdc++.h>
int main()
{
    char s[1001];
 while(~scanf("%s",s))
    {  if(strcmp(s,"0")==0)
    break;

        int sum=0;
        int n=strlen(s);
        for(int i=0; i<n; i++)
        {
            sum*=10;
            sum+=s[i]-'0';
            sum=sum%11;
        }
        if(sum==0)
           printf("%s is a multiple of 11.\n",s);
        else printf("%s is not a multiple of 11.\n",s);

    }
    return 0;
}

错误原因:

错误一:题目大数据每一次加入之后都要整除取余,应该大概是题目规定吧。这种题就这么做。

错误二:在字符串中,判断0结束需要用代码中strcmp函数来判断!

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值