第一次,关于STL入门

C - Gunner Ⅱ(set+map)
Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.
InputThere are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)
OutputFor each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.
Sample Input5 5
1 2 3 4 1
1 3 1 4 2Sample Output1
3
5
4
2
题意:n只鸟,杰克射击m次,给出鸟的高度和杰克射击的高度,按顺序输出射下的鸟。
注意同样高度的鸟先射掉左边的
简单的STL
AC代码

#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<map>
#include<cmath>
#include<vector>
#include<set>
using namespace std;
int main()
{
    map<int,set<int> >x;
    set<int>::iterator it;
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int q;
        for(int i=1;i<n+1;i++)
        {scanf("%d",&q);x[q].insert(i);}
        while(m--)
        {
            scanf("%d",&q);
            it=x[q].begin();
            if(it==x[q].end())printf("-1\n");
            else
                printf("%d\n",*it);
            x[q].erase(*it);
        }
        x.clear();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值