PAT甲级——A+B Format

PAT甲级——A+B Format

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where -10​6≤a,b≤10​6. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

1000000 9

Sample Output:

-999,991

思路分析

将输入的两个数字相加,并赋值给字符串数组,然后从后往前扫描,每三位插入一个逗号。注意正负区别,负数前面要多一位。

参考代码

#include<iostream>
#include<string>
#include<sstream>
#include<math.h>
 
using namespace std;

int main(){
	//输入数据
	int a,b,sum;
	cin>>a>>b;
	sum=a+b;
	
	//判断正负 	
	bool isNeg_sum=false;
	if(sum<0){
		isNeg_sum=true;
		sum=abs(sum);
	}
	
	//插入字符
	string strSum;
	stringstream s;
	s<<sum;
	s>>strSum;
	int i;
	for(i=strSum.length()-3;i>0;i-=3){
		strSum.insert(i,",");
	}
	
	// 输出
	if(isNeg_sum){
		strSum.insert(0,"-");
	}
	cout<<strSum;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值