PAT甲级——1001 A+B Format (20分)

PAT甲级——1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6 ≤ a,b ≤ 10​6. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

题目大意

计算 a + b 的值,并以标准格式输出,数字需要用逗号分隔(除非少于四位数)。

分析

可以先将得到的 int 型的 a+b 转化成 string 型,并定义一个 string 类型的 f,然后从后往前遍历,一个个的添加到 f 中,并且以每三个为一组,若这三个全为数字并且下一组的第一个也为数字的话,就增加一个 ‘,’,因为是从后往前遍历,所以要将 f 反转才能得到最后的答案。

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int a,b;
	cin>>a>>b;
	string s=to_string(a+b);	// 将int型转化成string型 
	string f="";
	int cnt=0;
	for(int i=s.length()-1;i>=0;i--){
		if(isdigit(s[i])){
			if(cnt%3==0&&cnt!=0){
				f+=',';
			}
			cnt++;
		}
		f+=s[i];
	}
	reverse(f.begin(),f.end());
	cout<<f<<endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值