POJ 2387 dijkstra+链式前向星+优先队列优化(模板)

题目链接:>_>

题目:

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input
Line 1: Two integers: T and N
Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.

Output
Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output
90

Hint
INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.

题目大意:

1~n的最短路

解题思路:

dijkstra

代码:

#include<bits/stdc++.h>
using namespace std;
#define maxn 0x73f3f3f

struct node {
	int  to, w, next;
}x[100015];

int head[100015];
int foot[100015];
int cnt;
priority_queue<node> Q1;

bool operator < (node a, node b) {
	return a.w > b.w;
}

void add(int start, int endd, int w) {
	x[cnt].to = endd;
	x[cnt].w = w;
	x[cnt].next = head[start];
	head[start] = cnt++;
	
}

void init() {
	cnt = 0;
	memset(head, -1, sizeof(head));
	memset(x, 0, sizeof(x));
	memset(foot, maxn, sizeof(foot));
}

int main() {
	int n, m;
	while (~scanf("%d %d", &m, &n)) {
		init();
		for (int i = 0; i < m; i++) {
			int q1, q2, q3;
			scanf("%d %d %d", &q1, &q2, &q3);
			add(q1, q2, q3);
			add(q2, q1, q3);
		}
		node z = { 1,0,0 };
		Q1.push(z);
		foot[1] = 0;
		while (Q1.size()) {
			z = Q1.top();
			Q1.pop();
			int start = z.to;
			for (int i = head[start]; i != -1; i = x[i].next) {
				int endd = x[i].to;
				if (foot[endd] > foot[start] + x[i].w) {
					foot[endd] = foot[start] + x[i].w;
					Q1.push(x[i]);
				}
			}
		}
		printf("%d\n", foot[n]);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值