HDU-6188-Duizi and Shunzi(贪心)

Duizi and Shunzi

Problem Description

Nike likes playing cards and makes a problem of it.

Now give you n integers, ai(1≤i≤n)

We define two identical numbers (eg: 2,2) a Duizi,
and three consecutive positive integers (eg: 2,3,4) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate max(s).

Each number can be used only once.

Input

The input contains several test cases.

For each test case, the first line contains one integer n(1≤n≤106).
Then the next line contains n space-separated integers ai (1≤ai≤n)

Output

For each test case, output the answer in a line.

Sample Input

7
1 2 3 4 5 6 7
9
1 1 1 2 2 2 3 3 3
6
2 2 3 3 3 3 
6
1 2 3 3 4 5
 

Sample Output

2
4
3
2

Hint



Case 1123)(456)

Case 2123)(11)(22)(33)

Case 322)(33)(33)

Case 4123)(345

解题思路:

首先需要对牌排个序,然后从前往后遍历牌。
由于顺子需要3张牌而对子需要两张,所以优先选择出顺子。
当考虑牌i的时候,如果牌i-1和i-2都有剩余,那么牌i就可以和他们组成顺子,这样只消耗一张牌i,如果组对子就需要两张。剩下的然后再组成对子。这样就可以保证答案是正确的。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
const int N = 1e6+10;
using namespace std;
typedef long long ll;

ll a[N];
ll cnt[N];

int main()
{
    ll n;
    while(~scanf("%lld",&n))
    {
        memset(cnt,0,sizeof(cnt));
        for(int i = 0 ; i < n ; i ++)
        {
            scanf("%lld",&a[i]);
            cnt[a[i]] ++;
        }
        sort(a,a+n);
        ll ans = 0;
        for(int i = 0 ;i < n ; i ++)
        {
            if(a[i] <= 2)
            {
                ans +=cnt[a[i]]/2;
                cnt[a[i]] = cnt[a[i]]%2;
            }
            else if(cnt[a[i]-1] && cnt[a[i]-2] && cnt[a[i]])
            {
                cnt[a[i]] --;
                cnt[a[i]-2] --;
                cnt[a[i]-1] --;
                ans ++;
            }
            ans += cnt[a[i]]/2;
            cnt[a[i]] = cnt[a[i]]%2;
        }
        printf("%lld\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值