HDU-4734 F(x) (数位DP)

77 篇文章 0 订阅

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13

题目大意:统计区间[0,b]中的数x满足f(x)<=f(a)的个数?

好不容易遇见一个较为简单的数位DP,结果忘了求f(a),直接传入a,还debug半天...

看数据范围可以知道,max(f(x))=f(999999999)=4599,所以设dp[25][4615]即够

dp[i][j]表示长度为i的数,f(x)大小不超过j的数的个数

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,len,bit[25];
int a,b;
int dp[25][4615];//dp[i][j]表示长度为i的数,f(x)大小不超过j的数的个数

int dfs(int pos,int rem,bool limit) {//pos表示当前考虑的位,rem表示还剩余多少数,limit表示当前位是否有限制
    if(pos<=0) {
        return rem>=0?1:0;
    }
    if(rem<0) {//如果剩余的数小于0,则剪去
        return 0;
    }
    if(!limit&&dp[pos][rem]!=-1) {
        return dp[pos][rem];
    }

    int mx=limit?bit[pos]:9;
    int res=0;
    for(int i=0;i<=mx;++i) {
        res+=dfs(pos-1,rem-i*(1<<(pos-1)),limit&&i==mx);
    }
    if(!limit&&dp[pos][rem]==-1) {
        dp[pos][rem]=res;
    }
    return res;
}

int f(int x) {
    int res=0,w=1;
    while(x>0) {
        res+=(x%10)*w;
        w<<=1;
        x/=10;
    }
    return res;
}

int getCnt(int x) {//返回[0,x]中满足题意的数的答案
    len=0;
    while(x>0) {
        bit[++len]=x%10;
        x/=10;
    }
    return dfs(len,f(a),true);
}

int main() {
    int T,kase=0;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&T);
    while(kase<T) {
        scanf("%d%d",&a,&b);
        printf("Case #%d: %d\n",++kase,getCnt(b));
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值