poj2478——欧拉函数

题目链接:http://poj.org/problem?id=2478

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题目翻译:

法理序列Fn是指对于任意整数n( n >= 2),由不可约的分数a/b(0 < a < b <= n),gcd(a,b) = 1升序排列构成的序列,最开始的几个如下
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

你的任务是计算法理序列Fn中的元素个数。

Input

输入包含多组样例. 每组样例仅一行, 有一个正整数n (2 <= n <= 10 6). 两组样例间无空行. 0代表输入结束.

Output

对于每种情况,你需要输出法理序列Fn中包含元素的个数

 

前缀和以及欧拉函数的结合,元素个数就是小于等于n的所有数的欧拉函数的值。

#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;
const int maxn=1e6;
ll phi[maxn+1];
void init(){
	for(int i=1;i<=maxn;++i) phi[i]=i;
	for(int i=2;i<=maxn;i+=2) phi[i]/=2;
	for(int i=3;i<=maxn;i+=2)
		if(phi[i]==i)
			for(int j=i;j<=maxn;j+=i)
				phi[j]=phi[j]/i*(i-1);
	for(int i=3;i<=maxn;++i)
		phi[i]+=phi[i-1];
}
int main(){
	int n;
	init();
	while(~scanf("%d",&n)){
		if(n==0) break;
		printf("%lld\n",phi[n]);
	}
	return 0;
}

 

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值