Moving Tables ——经典贪心和区间覆盖问题

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

 

 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

 

 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 

line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

10 20 

30 40 

50 60 

70 80 

1 3 

2 200 

10 100 

20 80 

30 50 

Sample Output

10

20

30

/*经典简单贪心题,并且结合了区间覆盖的问题,思路很简单,就是不管是奇数还是偶数房间,都把他存放在走廊数组a中。很容易发现一个规律,就是相对应的房间奇数号n和偶数房间号n+1,对于走廊来说位置是(n+1)/2;以后每次都把区间内的数都加10,最后取所有数中的最大值就行!!!!
*/
#include <bits/stdc++.h>
using namespace std;
int a[205];
int main(){
    int T,begin,end;
     cin>>T;
     while(T--)
      {
         memset(a,0,sizeof(a)); //创建数组并初始化为0;
         int n;
        cin>>n;
        for(int i=1;i<=n;i++){
             cin>>begin>>end;
             if(end<begin)
                 swap(begin,end);//不论是大房间到小房间,还是小房间到大房间,都转化成小房间到大房间。
             for(int j=(begin+1)/2;j<=(end+1)/2;j++)             
                 a[j]+=10;//对走廊数组处理
        }
         int min_time=0;
        for(int i=1;i<=200;i++)
         min_time=max(min_time,a[i]);//求最小时间
        cout<<min_time<<endl;
      }
    return 0;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值