题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1880
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
Sample Output
light the wand
accio
what?
what?
这个题的难点不在于哈希,而是输入输出的处理。
我们可以用结构数组实现,用来存储哈希值和对应的字符串,之后每次回答的时候根据哈希值直接输出对应串。
读入数据的方法很好,以后可以借鉴一下!!!!
#include<iostream>
#include<cstring>
#include<algorithm>
#define ull unsigned long long
using namespace std;
const ull P=999983;
const int maxn=1e5+7;
struct Hash{
ull num;
string s;
bool operator <(const Hash x)const{
return x.num<num;
}
}hash1[maxn],hash2[maxn],temp;
char ss[100];
int main()
{
int nn=0;
string pos,pre;
while(1){
char ch;
scanf("%c",&ch);
if(ch=='@') break;
if(ch!='[') continue;
ull p=P,num=0;
pre.clear();
char cc;
while(1){
scanf("%c",&cc);
if(cc==']') break;
pre.push_back(cc);
num+=cc*p;
p*=p;
}
getchar();
getline(cin,pos);
hash1[nn].num=num;
hash1[nn].s=pos;
int len=pos.size();
num=0,p=P;
for(int i=0;i<len;++i){
num+=pos[i]*p;
p*=p;
}
hash2[nn].num=num;
hash2[nn++].s=pre;
}
scanf("%s",ss);
int q;
scanf("%d",&q);
sort(hash1,hash1+nn);
sort(hash2,hash2+nn);
getchar();
while(q--){
getline(cin,pos);
int len=pos.length();
ull num=0,p=P;
if(pos[0]=='['){
for(int i=1;i<len-1;++i){
num+=pos[i]*p;
p*=p;
}
int xx;
temp.num=num;
xx=lower_bound(hash1,hash1+nn,temp)-hash1;
if(hash1[xx].num!=num) printf("what?\n");
else cout<<hash1[xx].s<<endl;
}
else{
for(int i=0;i<len;++i){
num+=pos[i]*p;
p*=p;
}
int xx;
temp.num=num;
xx=lower_bound(hash2,hash2+nn,temp)-hash2;
if(hash2[xx].num!=num) printf("what?\n");
else cout<<hash2[xx].s<<endl;
}
}
}