POJ2406——经典哈希(求最大循环次数)

题目链接:poj.org/problem?id=2406

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目理解:

给一个串s,求出它的最大循环次数。

 

这个题用kmp也可以做,哈希也行。

先预处理求出能被整除的长度,并且哈希处理字符串

之后一个个枚举长度,找到符合条件的。

#include <iostream>
#include<vector>
#include<cstring>
#include<cstdio>
#define ull unsigned long long
using namespace std;
const int maxn=1e6+10;
const ull P=999983;
ull hash[maxn],p[maxn];
char s[maxn];
int main(int argc, char** argv) {
	p[0]=1;
	for(int i=1;i<=maxn;++i)
		p[i]=p[i-1]*P;
	while(~scanf("%s",s+1)){
		int len=strlen(s+1);
		if(len==1&&s[1]=='.') break;
		for(int i=1;i<=len;++i)
			hash[i]=hash[i-1]*P+(s[i]-'a'+1);
		vector<int> v;
		for(int i=1;i<=len;++i)
			if(len%i==0)
				v.push_back(i);
		int times=1;
		for(int i=0;i<v.size();++i){
			int flag=1;
			for(int j=v[i]*2;j<=len;j+=v[i]){
				if(hash[j]-hash[j-v[i]]*p[v[i]]!=hash[v[i]]){
					flag=0;
					break;
				}
			}
			if(flag){
				times=len/v[i];
				break;
			}
		}			
		printf("%d\n",times);
	}
	return 0;
}

 

 

  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值