poj1611——并查集基础题

题目链接:http://poj.org/problem?id=1611

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目翻译:

一起学猫叫病毒( Miaomiaomiao Together), 是一种原因不明的流行性病毒。从去年起,一起学猫成为新一代校园毒品,听到一起学猫叫这首歌的人很有可能就会感染这种病毒。由于它传染性很强( 只要你周围有人唱一起学猫叫,你很有可能也会开始唱,并开始劝你的同学一起唱)它开始被认为是全球威胁。为了减少传播给别人的机会, 最好的策略是隔离可能的患者。

学校里有许多学生团体。同一组的学生经常彼此相通,一个学生可以同时加入几个小组。为了防止一起学猫叫病毒病毒的传播,cjluxk算法与程序设计协会收集了所有学生团体的成员名单。他们的标准操作程序如下:

一旦一组中有一个可能的患者, 组内的所有成员就都是可能的患者。

为了遏制这种病毒的传播,我们需要找到所有的患者。现在知道编号为0的如花妹妹(感染源)已经得了一起学猫叫病毒,请你设计程序 发现所有可能的患者。

 

Input

输入文件包含多组数据。

对于每组测试数据:

第一行为两个整数n和m, 其中n是学生的数量, m是团体的数量。0 < n <= 30000,0 <= m <= 500。

每个学生编号是一个0到n-1之间的整数,一开始只有0号的如花妹妹被视为患者。

紧随其后的是团体的成员列表,每组一行。

每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。

n = m = 0表示输入结束,不需要处理。

Output

对于每组测试数据, 输出一行可能的患者。

 

并查集基础题,对每个团体内的节点进行合并,最后统计所有点中与0节点属于同一个根节点的个数。

#include <iostream>
#include<cstdio>
using namespace std;
const int maxn=3e4+7;
int n,m,k;
int p[maxn];
int mp[maxn];
int find(int x){
	return p[x]==x?x:p[x]=find(p[x]);
}
int main(int argc, char** argv) {
	while(~scanf("%d%d",&n,&m)){
		if(n==0&&m==0) break;
		for(int i=0;i<=n;++i) p[i]=i;
		while(m--){
			scanf("%d",&k);
			int x;
			scanf("%d",&x);
			int xx=find(x);
			for(int i=1;i<k;++i){
				int y;
				scanf("%d",&y);
				int yy=find(y);
				if(xx!=yy) p[yy]=xx;
			}	
		}
		int ans=1;
		int cur=find(0);
		for(int i=1;i<n;++i){
			int xx=find(i);
			if(xx==cur)
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值