hdu2147——bash博弈(打P-N表找规律)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2147

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.
 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

5 3
5 4
6 6
0 0

Sample Output

What a pity!
Wonderful!
Wonderful!

题目翻译:

‎最近基基没有关系。当她感到无聊时,他脑子里浮现了一个想法,她只是玩棋盘游戏。棋盘的大小是n_m.首先,一枚硬币被放置在右上角(1,m)。每次一个人可以移动硬币到左边,下面或左边的空白。不能移动的人会输掉比赛。基基玩它与ZZ。游戏总是从kiki开始。如果两者都踢得完美,谁会赢得比赛?‎

‎输入‎

‎输入包含多个测试用例。每行包含两个整数 n,m(0<n,m<#2000)。当 n=0 和 m=0 时,输入终止。‎
 

‎输出‎

‎如果基基赢得比赛打印f"太棒了!‎

‎示例输入‎

‎最近基基没有关系。当她感到无聊时,他脑子里浮现了一个想法,她只是玩棋盘游戏。棋盘的大小是n_m.首先,一枚硬币被放置在右上角(1,m)。每次一个人可以移动硬币到左边,下面或左边的空白。不能移动的人会输掉比赛。基基玩它与ZZ。游戏总是从kiki开始。如果两者都踢得完美,谁会赢得比赛?‎

‎输入‎

‎输入包含多个测试用例。每行包含两个整数 n,m(0<n,m<#2000)。当 n=0 和 m=0 时,输入终止。‎
 

‎输出‎

‎如果基基赢得比赛打印f"太棒了!‎

‎示例输入‎

 

算是巴什博弈的变形题,而且需要自己去打个PN表找规律。

#include<iostream>
using namespace std;
int main(){
	int n,m;
	while(~scanf("%d%d",&n,&m)&&n&&m){
		if(n%2==1&&m%2==1) printf("What a pity!\n");
		else printf("Wonderful!\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值