PAT A1008 Elevator (20 分)

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

分析:

用一个指针currfloor表示当先所在楼层,初始为0, 每次读入目标楼层floor之后与当前楼层比较:

floor大于currfloor,表示上楼,时间(floor-currfloor)*6+5

floor小于currfloor,表示下楼,时间(currfloor-floor)*4+5

floor等于currfloor,表示不变,但也要计算停留时间5s

第一次提交没考虑到等于的情况,有些测试点没通过。

启示:题干并没有说不存在楼层不变的情况,边界情况要考虑充分。

通过代码:

#include <bits/stdc++.h>
using namespace std;

int main()
{
	int n;
	cin>>n;
	int time = 0;
	int currfloor = 0;
	for(int i=0;i<n;i++){
		int floor;
		cin>>floor;
		if(floor > currfloor){
			time = time + (floor - currfloor)*6+5;
		}
		else if(floor < currfloor){
			time = time + (currfloor - floor)*4 + 5;
		}
		else{
			time += 5; 
		} 
		currfloor = floor;

	}
	cout<<time<<endl; 
	

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值