POJ 2348 Euclid's Game

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
25 7
11 7
4 7
4 3
1 3
1 0
an Stan wins.

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input
34 12
15 24
0 0

Sample Output
Stan wins
Ollie wins

题目大意:

给你两个自然数 a,b,这两个数(a,b)一个大一个小,S和O两人轮流用大数减小数的倍数,谁先减出0谁赢

分析:

看见题目是game马上就想到博弈,但是题目上的例子一直没有理解,因为博弈一般都是选择最优策略
(25,7)——>(25 - 7 * 2); 之前一直不知为什么不减7 * 3,之后发现S可以控制局面

前提假设 a > b
可以很轻松的推出:当 a = xb 时, 先手S可以控制局面,创造自己必赢的局面;
如果 a - b < b ,就需要记录一下一共有几步,最后判断一下奇偶,奇数先手S赢,偶数后手O赢

代码如下

#include<iostream>

using namespace std;

int main (void)
{
    int a, b;
    while(cin >> a >> b)
    {
        if (a == 0 && b == 0)
            break;
        int flag = 1;
        if (a < b)
        {
            int t = a;
            a = b;
            b = t;
        }
        while (b != 0)
        {
            if (a % b == 0 || a - b > b)
             //还可以是这样 if( a / b >= 2 || a == b)
            // 出现这样的局面先手S可以创造一个自己必赢的局面(也算是最优策略吧
                break;
            a -= b;
            flag++;
            if (a < b)
            {
                int t = a;
                a = b;
                b = t;
            }
        }
        if (flag % 2 != 0)
            cout << "Stan wins" << endl;
        if (flag % 2 == 0)
            cout << "Ollie wins" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值