渡河问题

Crossing River
题目描述:
Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input

1
4
1 2 5 10
Sample Output

17

解题思路:
n=1 ,就自己过去;
n=2 ,取时间长的
n=3,三人时间之和
n>=4,就会有两种情况来达到最优解:
1.始终让最快的单独划船。 最快的和最慢的一起渡河,然后最快的划回来,最快和次慢的一起渡河,最快的再回来。所用时间为 s[n]+s[1] + s[n-1] +s[1]

2.让最快和次快的先过河,最快的划回来,接着最慢和次慢的过河,让次快的划回来。 这样所用时间为 s[2]+s[1]+s[n]+s[2]

两种决策取时间最短的。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double N = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define MAXN 100010

int T,n;
int a[1010];
int sum;
int min(int a,int b)
{
    return a>b?b:a;
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        CL(a, 0);
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        sort(a+1, a+n+1);
        sum=0;
        while(n)
        {
            if(n == 1)
            {
                sum+=a[1];
                break;
            }
            else if(n==2)
            {
                sum+=a[2];
                break;
            }
            else if(n==3)
            {
                sum+=a[3]+a[1]+a[2];
                break;
            }
            else
            {
                sum+=min(a[2]*2+a[1]+a[n],a[1]*2+a[n]+a[n-1]);
                n-=2;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值