Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

解题思路:
我认为最核心的思想就是动态方程,也就是a[i][j]=max(a[i-1][j],a[i-1][j-w[i]]+v[i])。什么意思呢,a[i][j]代表的就是到装第i个物品占空间是j的背包价值,a[i][j]等于同样重量装上一个物品a[i-1][j]与减去当前物品重量的装上一个物品时的价值a[i-1][j-w[i]]+v[i]的最大值。只要你搞懂了这个动态方程的意思,也就差不懂明白了。
AC代码:

#include<bits/stdc++.h>
using namespace std;
int v[1010],w[1010];
int a[1010][1010];
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		memset(a,0,sizeof(a));
		int N,V; 
		cin >> N >> V;
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&v[i]);
		}
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&w[i]);
		}
		for(int i=1;i<=N;i++)
		{
			for(int j=0;j<=V;j++)
			{
				if(j>=w[i])
				{
					if(a[i-1][j]>(a[i-1][j-w[i]]+v[i]))
					{
						a[i][j]=a[i-1][j];
					}
					else
					    a[i][j]=a[i-1][j-w[i]]+v[i];
				}
				else
				    a[i][j]=a[i-1][j];
			}
		}
		printf("%d\n",a[N][V]);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值