HDU-2602Bone Collector(背包水题)

17 篇文章 0 订阅

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

题目中文描述:
问题描述
许多年前,在泰迪的家乡,有一个人被称为“骨头收藏家”。这个男人喜欢收集各种各样的骨头,比如狗狗,牛,还有他去了坟墓…
骨头收集器有一个大容量V的袋子,沿着他的收集之旅有很多骨头,显然,不同的骨骼具有不同的值和不同的体积,现在根据他的行程给出每个骨骼的值,你能计算出骨骼采集器可以得到的总值的最大值吗?

输入
第一行包含整数T,个案数。
接下来是T个案例,每个案例有三行,第一行包含两个整数N,V,(N <= 1000,V <= 1000)表示骨骼的数量和他的包的体积。第二行包含表示每个骨骼值的N个整数。第三行包含表示每个骨骼体积的N个整数。

产量
每行一个整数,表示总值的最大值(此数字将小于2 31)。

样本输入
1
5 10
1 2 3 4 5
5 4 3 2 1

样本输出
14

刚开始学动态规划,注释如果有不对的地方,欢迎指正

01 背包问题特点是:

每种物品仅有一件,可以选择放或不放。用子问题定义状态:**即F[i;v] 表示前i 件物品
恰放入一个容量为v的背包可以获得的最大价值。**则其状态转移方程便是:
F[i;v] = maxfF[i-1;v];F[i-1;v-Ci] + Wig
这个方程非常重要,基本上所有跟背包相关的问题的方程都是由它衍生出来的。所以有必要将它详细解释一下:

“将前i 件物品放入容量为v的背包中”这个子问题,若只考虑第i 件物品的策略(放或不放),那么就可以转

化为一个只和前i-1件物品相关的问题。如果不放第i 件物品,那么问题就转化为“前i-1件物品放入容量为v的

背包中”,价值为F[i-1; v];如果放第i 件物品,那么问题就转化为“前i-1件物品放入剩下的容量为v-Ci 的

背包中”,此时能获得的最大价值就是F[i-1;v-Ci] 再加上通过放入第i 件物品获得的价值Wi。


代码:

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<set>
#include<map>
#include<stack>
#include<vector>
#include<queue>
#include<iostream>
#include<algorithm>
#define ll long long
using namespace std;

struct node {
	int x, y;
}S[10020];

int main() {
	int t;
	int dp[1005];//dp数组
	while (cin >> t) {
		while (t--) {
			int n, m;
			int h;
			memset(dp, 0, sizeof(dp));
			cin >> n >> m;
			for (int i = 1; i <= n; i++) {
				cin >> S[i].x;//.x存储价值
			}
			for (int i = 1; i <= n; i++) {
				cin >> S[i].y;//.y存储体积
			}
			for (int i = 1; i <= n; i++) {
				for (int j = m; j >= S[i].y; j--) {//dp的题都要找状态转移方程!找方程,听听!
				//这是ren话嘛!!我学数学都没受过这委屈!QAQ
					dp[j] = max(dp[j], (dp[j - S[i].y]) + S[i].x);
				}//取dp[j]和dp[j - S[i].y] + S[i].x之间的最大值
			}
			cout << dp[m] << endl;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值