大数求余

题目描述

As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

输入

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

输出

For each test case, you have to ouput the result of A mod B.

样例输入

2 3
12 7
152455856554521 3250

样例输出

2
5
1521

分析:

此题重点考察大数取余。
我们会发现一个规律。
123456 mod 7
即:
https://blog.csdn.net/qq_32779119/article/details/79513480

#include"stdio.h"
#include"string.h"
int main()
{
    char a[1001];
    int B;
    int mod;
    int i,j,l;
    while(~scanf("%s %d",a,&B))
    {   mod=0;
        l=strlen(a);
        for(i=0;i<l;i++)
        {
            mod=(mod*10+(a[i]-'0'))%B;
        }
      printf("%d\n",mod);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值