题目描述:
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题意:
给出你存钱罐的初始重量和当前重量。 给出你每种硬币的重量和价值。问存钱罐里面的钱最少是多少。
分析:
熟悉了完全背包的话,这个也就能看出来时完全背包了。 不过又和普通的完全背包有些不同。 一般的完全背包都是求最大值。 但是这个却是求最小值。 所以初始值要为INF。然后还有确定边界值。 我们可以知道如果重量为0.那么里面的没有钱。所以dp[0]=0;
接下来就可以跑一遍完全背包了。
#include"string.h"
#include"functional"
#include"iostream"
#include"algorithm"
using namespace std;
typedef long long ll;
#define scanll(a,b) scanf("%I64d%I64d",&a,&b);
#define scanl(a) scanf("%I64d",&a);
#define scanff(a,b) scanf("%lf%lf",&a,&b);
#define scan1f(a) scanf("%lf",&a);
#define prinll(a,b) printf("%I64d %I64d",a,b);
#define prinl(a) printf("%I64d",a);
#define printff(a,b) printf("%lf %lf",a,b);
#define printlf(a) printf("%lf",a);
#define OK printf("\n");
#define MAXSIXE 310
#define INF 10010010
int main()
{
ll T;
while(~scanf("%lld",&T))
{
while(T--)
{
ll E,T;
scanll(E,T);
ll V=T-E;
ll N;
scanl(N);
ll p[510];
ll w[510];
ll dp[10010];
for(ll i=0;i<=V;i++) dp[i]=INF;
for(ll i=1;i<=N;i++)
scanll(p[i],w[i]);
dp[0]=0;
for(ll i=1;i<=N;i++)
{
for(ll j=w[i];j<=V;j++)
{
dp[j]=min(dp[j],dp[j-w[i]]+p[i]);
}
}
if(dp[V]!=INF)
printf("The minimum amount of money in the piggy-bank is %lld.\n",dp[V]);
else
printf("This is impossible.\n");
}
}
}