分数的四则运算 (PATA1081,PATA1088)

像这种类型是有模版的
直接套模版就行
1、定义结构体

struct Fraction{
	int up,down; // up表示分母,down表示分子
}

2、取得一个分数后,须化简

Fraction reduction(Fraction result){
	if (result.down < 0){
		result.up = -result.up;
		result.down = -result.down;
	}
	if(result.up == 0){
		result.down = 1
	}else{
		int d = gcd(abs(result.up),abs(result.down));
		result.up /= d;
		result.down /= d;
	}
	return result;
}

3、四则运算

Fraction add(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down + f2.up*f1.down;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction minus(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down - f2.up-f1.down;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction multi(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.up;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction divide(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down;
	result.down = f1.down*f2.up;
	return reduction(result);
}

4、输出格式

void printFraction(Fraction result){
	result = reduction(result);
	if (result.down == 1){
		printf("%d\n",result.up)
	}else if (result.up > result.down){
		printf("%d %d/%d\n",result.up/down,abs(result.up)/result.down,result.down);
	}else{
		printf("%d/%d\n",result.up,result.down);	
	}
}

例题1

PAT A 1081 Rational Sum(20)
Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

思路:
直接套模版,需要注意的是数据范围为整型,相乘的时候会超出int,要用long long。

代码:

#include<cstdio>
#include<cstdlib>
struct Fraction
{
	long long up,down;
};

long long gcd(long long a,long long b){
	if (b == 0)return a;
	else return gcd(b,a%b);
}

Fraction reduction(Fraction result){
	if (result.down < 0){
		result.up = -result.up;
		result.down = -result.down;
	}
	if (result.up == 0){
		result.down = 1;
	}else{
		long long d = gcd(abs(result.up),abs(result.down));
		result.up /= d;
		result.down /= d;
	}
	return result;
}

Fraction add(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down + f2.up*f1.down;
	result.down = f1.down*f2.down;
	return reduction(result);
}

void showResult(Fraction result){
	result = reduction(result);
	if (result.down == 1)printf("%lld\n",result.up );
	else if (abs(result.up) > result.down){
		printf("%lld %lld/%lld\n",result.up/result.down,abs(result.up%result.down),result.down );
	}else{
		printf("%lld/%lld\n", result.up,result.down);
	}
}

int main(){
	int n;
	scanf("%d",&n);
	Fraction result,temp;
	result.up = 0;
	result.down = 1;
	for (int i = 0; i < n; ++i)
	{
		scanf("%lld/%lld",&temp.up,&temp.down);
		result = add(result,temp);
	}
	showResult(result);
	return 0;
}

例题2

PAT A 1088 Rational Arithmetic(20)
For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

思路:
1、还是套模版,数据范围为int整型,当两个数相乘时会越界,要用long long 。
2、除法时,0不能带入divide函数作除数,需要先条件判断

代码:

#include<cstdio>
#include<cstdlib>
typedef long long ll;
struct Fraction
{
	ll up,down;
};

ll gcd(ll a,ll b){
	if (b == 0)return a;
	else return gcd(b,a%b);
}

Fraction reduction(Fraction result){
	if (result.down < 0){
		result.up = -result.up;
		result.down = -result.down;
	}
	if (result.up == 0){
		result.down = 1;
	}else{
		ll d = gcd(abs(result.up),abs(result.down));
		result.up /= d;
		result.down /= d;
	}
	return result;
}

Fraction add(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down + f2.up*f1.down;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction minus(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down - f2.up*f1.down;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction multi(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.up;
	result.down = f1.down*f2.down;
	return reduction(result);
}

Fraction divide(Fraction f1,Fraction f2){
	Fraction result;
	result.up = f1.up*f2.down;
	result.down = f1.down*f2.up;
	return reduction(result);
}

void showResult(Fraction r){
	r = reduction(r);

	if (r.up < 0)printf("(");
	if (r.down == 1){
		printf("%lld", r.up);
	}else if (abs(r.up) > r.down){
		printf("%lld %lld/%lld",r.up/r.down,abs(r.up)%r.down,r.down);
	}else{
		printf("%lld/%lld",r.up,r.down);
	}
	if (r.up < 0)printf(")");

}

int main(){
	Fraction a,b;
	scanf("%lld/%lld %lld/%lld",&a.up,&a.down,&b.up,&b.down);
	// 加法
	showResult(a);
	printf(" + ");
	showResult(b);
	printf(" = ");
	showResult(add(a,b));
	printf("\n");
	// 减法
	showResult(a);
	printf(" - ");
	showResult(b);
	printf(" = ");
	showResult(minus(a,b));
	printf("\n");
	// 乘法
	showResult(a);
	printf(" * ");
	showResult(b);
	printf(" = ");
	showResult(multi(a,b));
	printf("\n");
	// 除法
	showResult(a);
	printf(" / ");
	showResult(b);
	printf(" = ");
	if (b.up == 0){
		printf("Inf");
	}else{
	showResult(divide(a,b));
	}
	printf("\n");

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值