线性结构3 Reversing Linked List

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>

#define N 100005

typedef struct
{
    int address;
    int data;
    int next;
}Node;

Node list[N+1];

void input(int n);
int count(int head);
int reverse(int head,int n,int k);
void print(int next);

int main()
{
    int n,k,head;
    scanf("%d %d %d",&head,&n,&k);
    input(n);
    head=reverse(head,n,k);
    print(head);
    return 0;
}

void input(int n)
{
    int address,data,next,i;
    for (i=0;i<n;i++)
    {
        scanf("%d %d %d",&address,&data,&next);
        list[address].address=address;
        list[address].data=data;
        list[address].next=next;
    }
    return;
}

int count(int head)
{
    int count=0,next=head;
    while (next!=-1)
    {
        count++;
        next=list[next].next;
    }
    return count;
}

int reverse(int head,int n,int k)
{
    int i,j,position=N,tail,front=head,rear=list[front].next,t,z;
    z=count(head)/k;
    for (i=1;i<=z;i++)
    {
        tail=front;
        for(j=1;j<k;j++)
        {
            t=list[rear].next;
            list[rear].next=front;
            front=rear;
            rear=t;
        }
        list[position].next=front;
        position=tail;
        list[position].next=rear;//tail是每组交换完成之后最后一个元素的位置,position存的是交换完成后第一个元素的位置
        front=rear;
        rear=list[front].next;
    }
	if(z) list[position].next=front;
    else list[position].next=-1;
    return list[N].next;
}

void print(int head)
{
    int next=head;
    while (list[next].next!=-1)
    {
        printf("%05d %d %05d\n",list[next].address,list[next].data,list[next].next);
        next=list[next].next;
    }
    printf("%05d %d %d\n",list[next].address,list[next].data,list[next].next);
    return;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值