A1016

Phone bills

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.
Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

注意点

1, 排序只有一个标准,cmp是非常好写的。
2,细节1,编写一对通话记录的费用,可以采用累加法或者从零计数法。累加法每次一个分钟增加。从零计数法: cost = days * 60 * sum(bill[1…24]) + sum(60 * bill[1…hours]) + bill[hours] * minutes.
3, 细节2, 双循环实现找到多个用户的多条配对记录。若没有则不输出。
4, 测试用例3没有通过,原来是总时长格式输出只要%d就可以了。否则样例3过不了。

代码

#include<bits/stdc++.h>
using namespace std;
typedef struct node{
	string name;
	int MM;
	int dd;
	int hh;
	int mm;
	int state;
}Record;
Record record[1010];
int bill[26];
bool cmp(Record a, Record b){
	if(a.name!=b.name) return a.name<b.name;
	else if(a.MM!=b.MM) return a.MM<b.MM;
	else if(a.dd!=b.dd) return a.dd<b.dd;
	else if(a.hh!=b.hh) return a.hh<b.hh;
	else return a.mm<b.mm;
	
}
void get_bill(Record a, Record b, int &time, double &once){
	int dd=a.dd;
	int hh=a.hh;
	int mm=a.mm;
	while(!(dd==b.dd&&hh==b.hh&&mm==b.mm)){
		once=once+bill[hh]*1.0;
		time++;
		mm++;
		if(mm==60){
			mm=0;
			hh++;
		}
		if(hh==24){
			dd++;
			hh=0;
		}
	}
}
int main(){
	int n;
	for(int i=0;i<24;++i){
		scanf("%d",&bill[i]);
	}
	scanf("%d",&n);
	for(int i=0;i<n;++i){
		string str;
		cin>>record[i].name;
		scanf("%d:%d:%d:%d",&record[i].MM,&record[i].dd,&record[i].hh,&record[i].mm);
		cin>>str;
		if(str=="on-line") record[i].state=1;
		else if(str=="off-line") record[i].state=2;
		else record[i].state=0;
		
	}
	sort(record,record+n,cmp);
	for(int i=0;i<n;){
		int needPrint=0;
		int j=i;
		while(j<n&&record[j].name==record[i].name){
			if(needPrint==0&&record[j].state==1){
				needPrint=1;
			}else if(needPrint==1&&record[j].state==2){
				needPrint=2;
			}
			++j;
		}
		if(needPrint<2){
			i=j;
			continue;
		}
		cout<<record[i].name;
		printf(" %02d\n",record[i].MM);
		double total=0.0;
		while(i<j){
			if(i+1<j&&record[i].state==1&&record[i+1].state==2){
				int time=0;
				double once=0.0;
				get_bill(record[i],record[i+1],time, once);
				printf("%02d:%02d:%02d %02d:%02d:%02d %02d $%.2lf\n",record[i].dd,record[i].hh,record[i].mm,record[i+1].dd,record[i+1].hh,record[i+1].mm,time,once);
				total = total+once;
			}	
			++i;
		}
		printf("Total amount: $%.2lf\n",total/100.0);
		i=j;
	}
	return 0;
}
/*
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
5
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:02:00:02 off-line

*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值