SDUTOJ 3375 - 数据结构实验之查找三:树的种类统计

Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

Sample Input

2
This is an Appletree
this is an appletree

Sample Output

this is an appletree 100.00%

Hint
Source

xam


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

typedef struct node{
    char data[30]; // 存储字符串
    struct node* l; // 左指针
    struct node* r; // 右指针
    int count; // 出现次数
}tree;

char str[30]; // 每次输入的字符串
int n;

tree* build(tree* t){ // 建树
    if (t == NULL){ // 结点为空,则建结点
        t = (tree*)malloc(sizeof(tree));
        t->l = NULL;
        t->r = NULL;
        t->count = 1;
        strcpy(t->data, str);
    }
    else{ // 比较
        if (strcmp(str, t->data) == 0){ // 树种有相同结点则count+1
            t->count++;
        }
        else if (strcmp(str, t->data) < 0){ // 建立查找树
            t->l = build(t->l);
        }
        else {
            t->r = build(t->r);
        }
    }
    return t;
}

void show(tree* t){ // 按字典顺序输出,中序遍历
    if (t != NULL){
        show(t->l);
        printf("%s %.2lf%%\n", t->data, 100.0*t->count/n);
        show(t->r);
    }
}

int main(){
    tree* t = NULL;
    scanf("%d", &n);
    getchar(); // 吸收回车
    for (int i = 0; i < n; i++){
        gets(str); // 允许输入空格
        int len = strlen(str);
        for (int j = 0; j < len; j++){ // 统一为小写字母
            if (str[j] >= 'A'&&str[j] <= 'Z'){
                str[j] += 32;
            }
        }
        t = build(t);
    }
    show(t);
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值