计蒜客1047

计蒜客1047
题目:
Alice, a student of grade 666, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him.
The problem is:
We denote k!
k!: k!=1×2×⋯×(k−1)×k
We denote S
S: S=1×1!+2×2!+⋯+(n−1)×(n−1)!
Then S module n is ____________
You are given an integer nnn. You have to calculate S modulo n.

Input:

The first line contains an integer T(T≤1000), denoting the number of test cases. For each test case, there is a line which has an integer n.
It is guaranteed that 2≤n≤10.

Output

For each test case, print an integer S modulo n.

Hint

The first test is: S=1×1!=1 1 modulo 2 is 1.
The second test is: S=1×1!+2×2!=5, and 5 modulo 3 is 2.

样例输入
2
2
3

样例输出
1
2

#include <stdio.h>
int n(int dig); 
int S(int dig); 

int main() {   
 int cnt;    
 scanf("%d",&cnt);    
 int cnt1=cnt;    
 int dig;    
 int dig1[100];    
 int i=0;    
 while(cnt--){     
 scanf("%d",&dig);     
 dig1[i]=S(dig)%dig;    
 i++;   
}    
for(i=0;i<cnt1;i++){     
printf("%d\n",dig1[i]);   
}   
     return 0; 
} 

int n(int dig){
int i,rel;
rel=1;
for(i=1;i<=dig;i++){
rel*=i;
}
return rel;
}

int S(int dig){
 int i;
 int rel=0;
 for(i=1;i<dig;i++){
  rel+=i*n(i);
 }
 return rel;
}

放在计蒜客上面就超时了
直接用规律:

#include <stdio.h>
int main()
{
   int cnt;
   scanf("%d",&cnt);
   long long dig;    //注意这里的数据类型long  long
   int i=0;
   while(cnt--){
    scanf("%lld",&dig);  
    printf("%lld\n",dig-1); //直接将输入的数字减一就是结果
   }
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值